[SOLVED] HTML5 particlefx buffer set to 1

Hi there.

I’m still on my way to learn Defold, doing really simple stuff.

When i build my small project for HTML5, and test project inside Safari, the behaviour of the particles emitter is different than the one on desktop. Inspecting the JS console I found an error message regarding particlesfx :

ERROR:GAMESYS: Particle FX component buffer is full (1), component disregarded.

I’m not sure if this particle component buffer is about emitter or particles. Anyway, i just have 1 emitter with short life particles, so i doubt my usage would be able to overflow any kind of buffer. ( And a buffer size of 1 seems really weird to me, but i don’t know what exactly is this particle fx component ).

I’ve set the max particles count to 128 in the project, and according to the profiler, only 6 particles are alive at max at any given time, that seems right as i have only 1 small and very simple emitter for testing purposes.

Particles work as intended when project built in editor ( Command + B ).

I did not manage to find any other settings that were HTML5 particles specific.
And i didn’t manage to find something similar in the forum, discord or docs.

I’m using MacOS Big Sur 11.6.2, Safari 15.2, and Defold 1.2.191.

Sorry if i missed something obvious, but i don’t get it.
May i buy a shovel for deeper digging, or is it a bug ?
( I’ll gladly take some time to report it, but i don’t want to pollute the bug reports with something i’m not sure about ).

So guys ( and girls ), please, is that buffer size of 1 the normal state ? And if not, where the hell is its setting hidden ?

1 Like

Hi, could you please share an archive with the issue, it would help to figure out what the problem is.

Sure !

But i don’t want you to spend much time on it.
You certainly have much more urgent stuff to do.
Anyway, thanks, and apoligizes if i did something stupid.
practice_shooter.zip (3.2 MB)

PS: i’m leaving to work, be back late at night, so really there’s no urgence here.


This workaround will help you as a temp solution before the actual fix (in the next version, I think). Assertion failed: size <= Capacity() - #4 by AGulev

Your issue isn’t exactly the same, but the workaround is the same.


Thanks !
I hope i did not make you waste too much time, there was nothing critical as it is just me trying to tame Defold.

I’m not sure i understood correctly the workaround.
Do you mean using a GO factory as an emitter to spawn particles ?

No, I mean having a factory with any GO that has a particlefx component on it. It’s not necessary to create objects from this factory but have it in collection.

1 Like

Understood. Thanks again.

1 Like