Can't open project (SOLVED)

Thanks. We’ll do that…

Edit: Changed the text on the download link.


So I cannot run this even on plus 5 y.o. pc’s (running already 64 bit)?
Most other dev software even requires 64 bit.
When will this be working on 64 bit Linux and how can I help?
I am very surprised.
I did not see it mentioned at download time.
I will also wait for support for it.
Thank you.



The only thing stopping me from trying Defold is that it wont run on 64bit Ubuntu. Is there an eta for a 64bit linux version?


I’ve asked for any update on this from the rest of the team. Hopefully we’ll be able to provide more info next week when the entire team is back again.

If everything goes according to plan 64 bit Linux support will come in 1.2.75 that will be released on the 22nd of February.

1 Like


I see 1.2.75 is out. Is it 64bit Linux compatible?

1 Like

Ping @Ingela_Garneij

According to the release notes the feature didn’t make it into the release. Hopefully it will be included in the next release.

Yes! Our priorities change fast, so we cannot be so exact in our ETA dates. BUT, we are working on it as of today so it will come in our next release. Thanks for your understanding!

1 Like

I’m hoping this is still prioritized for the next release. Is there an ETA for that release?

In the meantime, though,

1 Like

Releases are made bi-weekly. I saw Linux 64-bit support it in the list of issues actively worked on during the last sprint at our daily stand-up

1 Like

You guys have the 64bit version listed on the home page but I am still getting the same error as the op

1 Like

Are you running the script?

1 Like

Run command ./ from terminal.

1 Like

I’m doing that and getting the error. Running 64-bit Defold on 64-bit Peppermint 6. I think running 1.2.75. I download it yesterday morning (EST). It prompts me to update and it seems to have downloaded everything, but when I restart Defold nothing seems to have happened. This engine seems to fail at the most fundamental things like supporting 64-bit Linux, showing what version your running, etc. At least for me it does. Defold seems nearly too good to be true, and sadly, it probably is.

Edit: Removed stuff about the downloads failing. Saw message at the top of forums.

Updating did not solve the problem either. Sorry for the double post.

1.2.80 is the latest version. Could you try to download and run this version directly?

Double check that you are actually on the latest version in the about.

I’m running the latest version, downloaded directly from the site and running it through the script. There’s no change in behavior whatsoever. The About box shows up as all white with a blinking cursor a the Defold Logo. Selecting everything in box highlights it so I can see it. I’m blaming that on my GTK theme witch has white text on a very very dark grey. (Almost Batman style) It says I have 1.2.80.

Do you get any errors? Could you check the error-panel at the bottom?

Any spaces in the path to the folder where your Defold installation is located?