Can't open project (SOLVED)

i have created project from the dashboard, but when i click open project from the editor, nothing happened, this is my first time using this engine. what should i do?

When you open a projec for the first time, you need to create a “branch”, whch is a copy of the project on your computer. Click “New branch” and name your local working copy (like “my work” or similar).

When you have a branch, you can open it in the editor.

and how to do that?, i think i’m missing something

Select “Open project” in the menu, then click then “New branch” button in the dialog that opens. See the image in my previous post.

Worth noting is that you’re actually not creating a new branch in the repo. New Branch simply makes a git clone of the master branch of the repo to a folder on disk (your_defold_install/branches/project_id/your_user_id/name_of_branch). If you want real branches you need to move to command line Git or a separate visual Git tool such as GitHub for Desktop, SourceTree or Git Tower.


i have clicked Open Project menu so many times, but still nothing happened, is this a bug? i’m using linux mint 17 btw

And what happens when you click New Branch? You should get an input box where you can select a name of the “branch” (folder on disk). The name you choose should then show up in the empty white area in Mikael’s screenshot. Once you’ve selected the branch from the list you should be able to choose Finish and your project will open.

Linux is the least tested of the Editor versions. I’m wondering if you’ve maybe encountered a bug.

it’s just not showing anything after i clicked the open project menu , not even the New Branch thing

That sounds like a missing dependency. Check the FAQ for some pointers.

If you start the editor from the terminal you will get error output there that helps tracking down what’s going on.

ok i have follow the instruction, but it still error

(Defold:3580): Gtk-WARNING **: Unable to locate theme engine in module_path: “adwaita”,
(Defold:3580): Gtk-WARNING **: Unable to locate theme engine in module_path: “adwaita”,
Gtk-Message: Failed to load module "unity-gtk-module"
ERROR: Resource type for extension ‘gui’ already registred (

Might have something to do with packages, by just looking at the error message?

The last error indicates that something else already is registered to handle .gui files. Check if that is something you can set in your window manager.

the package already installed, still no luck

Do you have some other program that opens .gui files when double-clicking them? If so, try to remove that configuration.

i don’t know, i never open file with that extension

Do you have several instances of the editor running? Try rebooting or kill stale processes?

Did you manage to get the editor to work properly?

Are you running Linux 32 or 64 bit? I’ve tried to run the editor on a 64 bit system and get similar errors you get. Unfortunately we don’t support 64 bit Linux at the moment, but I will talk to the team about it and see if it can be added.

yes, its 64bit
i’ll wait then :smile:

It doesn’t open a project with Ubuntu 14.04 x64 :

Gtk-Message: Failed to load module "overlay-scrollbar"
Gtk-Message: Failed to load module "unity-gtk-module"
ERROR: Resource type for extension ‘gui’ already registred (

You guys should make it more obvious in the Download button that’s is only for x32 bit Linux. Rather letting people search through FAQ and Forum.