Windows icon doesn’t work

I try to create a PC build, but every time I get this error:

Error - 2 icon(s) not replaced in C:\Users\scorp360\Documents\prooggrammmer\lua\Defold\projet\drop\+\v10 buyVersion\pc\buy\x86_64-win32\DR0P In Music\DR0PInMusic.exe using C:\Users\scorp360\Documents\prooggrammmer\lua\Defold\projet\drop\DR0P\bundle\win32\work2.ico

I have read many topics to solve the problem:

Même testé les .icon que vous dites fonctionnel, mais aucun ne fonctionne.

I have removed compress for windows Vista add all image for the icon, but it always doesn’t work.

I’ve test all the icon in the topic and all icon put the same error.

Have you got an idea of the problem ?

Thanks for advance. :slight_smile:


1 Like

:hushed: Oh, I get the same error now with ico files I have used without problems in previous projects.

I remember reading in changelog something was changed with Windows icons since those old posts. So people who made those changes would need to comment!

1 Like

We updated the in 1.3.6, in order to support larger icon sizes.

I don’t think that the actual documentation changed though :thinking:
But let’s ask @britzl if he recalls some info about this.

1 Like

Yes @jhonny.goransson updated to support 256px icons:

I don’t recall anything other than the fact that we needed to support 256px icons.

1 Like

The errors have always been there and are not really errors, but more like warnings. I think iconexe prints that line for all the icons it couldn’t replace in the exe you are trying to update. And I think we create the exe with just a few of the supported sizes but not all so if you are trying to update an exe with a size the original exe doesn’t have you will end up with that error.

Here’s the line if anyone is interested:

1 Like

Ok, it’s interesting.

I restart my Window and now the icon appears.
I have the impression that as long as I don’t restart Windows, it will keep the icon it has had since startup.

I also noticed a detail:
It is possible to test if all file sizes are there in the file explorer in view.