Problem with logging into the Defold Dashboard

#9

Unfortunately, no. Half the team is still on vacation, including our backend ppl.
They’re expected back on monday. But I’ll ping @mikael.lothman and @samuel.nystedt again.

1 Like

#10

That’s alright! Enjoy the rest of your holidays. You guys have a really good thing here.

4 Likes

#11

Would it be possible I could get the account I registered with deleted so I could try and create a new one?

0 Likes

#12

Hi @claviger! It looks like you have signed up with a non-Google e-mail account. Please ensure that you use a Google e-mail, otherwise the Google login will not work.

0 Likes

#13

Hi Mikael, I am unsure what you mean. Are you saying I must sign up with a gmail account? Because the email address I used to sign up with is the one I use with my google account. That is, the one that lets me sign into google services such as drive.

0 Likes

#14

Sorry for being unclear. Of course you should use your e-mail for your Google account. Have you tried Chrome browser?

0 Likes

#15

This is the email I use for my Google account so that is strange that it would appear to be a nongoogle account. I have tried using it on Chrome and Microsoft Edge as mentioned above, as well as trying Chrome on a different device with a different network entirely.

0 Likes

#16

Hi @claviger. I’m just back from holidays now, sorry for the delay. Is your email a G Suite account or is it created back when Google allowed custom domains for free gmail accounts?

1 Like

#17

I believe it is a custom domain as I have not used G Suite in the past.

1 Like

#19

Ok, do you use gmail with this Google account or is the email you use with this account hosted somewhere else? I think we had a similar issue before with old google accounts.

0 Likes

#20

If you check the developer console of your browser for these requests that get the 403 error. Can you see if the headers X-Auth and X-Email are set?

1 Like

#21

This google account uses a separate email using Vivaldi’s built in mail service. I checked and, at least where I could set a breakpoint to stay on the dashboard page rather than be redirected back to google login, the two headers are set. Also, I’m not super experienced using the web console, so where I found email and auth was in the cookies storage. Is this correct?

0 Likes

#22

If you’re in Chrome and open the Developer Tools you’ll find it on the request in the headers section:

2 Likes

#23

Ah okay thank you for the screenshots. Those definitely helped. Yes! The two headers are set.

1 Like

#24

I tried to reproduce this by creating a Vivaldi email, then creating a new Google account with it and signed up to Defold in the Vivaldi browser. It all worked fine for me. I tried logging in and out a couple of times without any problems.

@claviger we cleared your current sessions from our end, so if you try logging in again it may work better.

If you still have problems, could you try creating a fresh new google account and sign up with it to see if that works?

3 Likes

#25

@samuel.nystedt I have tried logging in with my account and it still does not work, but when I tried a different google account it did! Would it be possible that I could have my account be deleted so I could try to register again?

1 Like

#26

Great that the other google account worked. We have now removed your old broken account. Thanks for your patience and hope you’ll enjoy using Defold.

4 Likes

#27

Same Problem again, even with freshly created google account and all cookies cleared. cannot login to dashboard. Endless loop. Login works, but as soon as I want to go to “get defold” I’m stuck.
Please make the download available without this stupid login.

0 Likes

#28

You can try to download it from here http://d.defold.com/stable/

1 Like

#29

We are in the process of removing the Dashboard. The login will soon be history.

2 Likes