Problem with logging into the Defold Dashboard


#1

Hey I’m looking to try out Defold for an upcoming project. I am using Vivaldi as my browser, but also tried Microsoft edge and the same problem arises. When I try to log into the dashboard, the website prompts me to sign in with my google account, even if I am logged in already on defold.com. Then, when I login using google again, the browser navigates to dashboard, loads for about a second, and then redirects to the google login page. Checking the console, I appear to be getting the same two errors every time I try to log in.

create:1 GET https://cr.defold.com/users/MY_EMAIL_ADDRESS_HERE 403 ()
create:1 GET https://cr.defold.com/projects/53057 403 ()

I have tried clearing cookies and switching browsers as mentioned before.

Any help would be greatly appreciated as I am looking forward to trying out Defold.


#2

Hello @claviger and welcome to the forum! I’m sorry that your first experience with Defold is a login problem. Which OS are you using, Windows 10? What if you use Chrome?

Note that you don’t have to access the Dashboard to try Defold. You can create an empty game.project file in a new folder and then select Open from Disk and select the game.project file to start a new empty project.


#3

I am using Windows 10. I cannot even download Defold at this point, as the link to download requires a sign in with google. Using chrome, unfortunately I get the same issue.

From the defold.com start page, if I click “Get Defold”, that is where the issue begins.


#4

Oh, that sucks. Can you try from another network, perhaps tethered to your phone?

You should be able to download from https://www.defold.com/download/editor2/Defold-x86_64-win32.zip until we’ve figured out what’s wrong.


#5

Just tried using a different network, still no luck! The direct download worked, but I’ll still hold on for a bit to see if I can help you guys figure this out!


#6

Hmm, very strange. Are you sure about the e-mail you used when you signed up? I’m at the office tomorrow and hopefully there’s someone who can help me shed some light on this problem. Perhaps @mikael.lothman or @samuel.nystedt?


#7

Yeah it’s the same as I used for my forums account!


#8

Any news on a fix for this? I have since tried logging in from a different device and I seem to be getting the same issue. I believe it may be an account issue


#9

Unfortunately, no. Half the team is still on vacation, including our backend ppl.
They’re expected back on monday. But I’ll ping @mikael.lothman and @samuel.nystedt again.


#10

That’s alright! Enjoy the rest of your holidays. You guys have a really good thing here.


#11

Would it be possible I could get the account I registered with deleted so I could try and create a new one?


#12

Hi @claviger! It looks like you have signed up with a non-Google e-mail account. Please ensure that you use a Google e-mail, otherwise the Google login will not work.


#13

Hi Mikael, I am unsure what you mean. Are you saying I must sign up with a gmail account? Because the email address I used to sign up with is the one I use with my google account. That is, the one that lets me sign into google services such as drive.


#14

Sorry for being unclear. Of course you should use your e-mail for your Google account. Have you tried Chrome browser?


#15

This is the email I use for my Google account so that is strange that it would appear to be a nongoogle account. I have tried using it on Chrome and Microsoft Edge as mentioned above, as well as trying Chrome on a different device with a different network entirely.


#16

Hi @claviger. I’m just back from holidays now, sorry for the delay. Is your email a G Suite account or is it created back when Google allowed custom domains for free gmail accounts?


#17

I believe it is a custom domain as I have not used G Suite in the past.


#19

Ok, do you use gmail with this Google account or is the email you use with this account hosted somewhere else? I think we had a similar issue before with old google accounts.


#20

If you check the developer console of your browser for these requests that get the 403 error. Can you see if the headers X-Auth and X-Email are set?


#21

This google account uses a separate email using Vivaldi’s built in mail service. I checked and, at least where I could set a breakpoint to stay on the dashboard page rather than be redirected back to google login, the two headers are set. Also, I’m not super experienced using the web console, so where I found email and auth was in the cookies storage. Is this correct?