Importing Hero example from Spine has feet pointed downward

#1

Hey folks,

I’m having the same issue as shown to the Witcher character in this post:

However, the resolution of checking the rotation box does not solve my issue (they are already checked). Using the Hero example that comes with Spine, it looks and animates fine in the Spine Editor, but when imported into Defold, the feet are pointing downwards.

I tried importing the same exported data and images into GameMaker Studio 2, just to double check that it wasn’t an issue with the export, and it worked fine in there as well. This leads me to believe that it may be a bug in Defold. I was using the latest version of Spine (3.7.94) to export the JSON.

Any assistance with this will be greatly appreciated!

Cheers,
Dan.

0 Likes

#2

Defold supports Spine 2.x functionality so there is no guarantee that the model will work properly if it uses newer features. This is mentioned in the Spine manual. I think you can set a version when exporting. @sven?

0 Likes

#3

Looks like I can specify the version in the settings. As a new user, wanting to use both Defold and Spine, this makes the learning process extremely difficult, as the example projects will not work on that runtime.

It’s just the feet that are breaking… are you sure you guys can’t take a look?

0 Likes

#4

Did you apply the solution that Dragosha used? See this post: What's wrong with this Spine model? (SOLVED)

0 Likes

#5

This reply might come across as a little snarky, but there is NO snark intended.

I did, that’s why in my original post I referenced that exact forum post, commented that the solution to it did not work for me and included a screen shot showing Rotation on the foot joint checked, next to the screen shot of it as seen in Defold with still downward pointing feet.

0 Likes

#6

Gotcha! Can you share the model and images?

0 Likes

#7

Sure can, but I’m at work right now. I can zip them up and send them tonight.

0 Likes

#8

Ok, we’ll take a look on Friday then (Holiday tomorrow here in Sweden).

0 Likes

#9

I’d like to take a look at this as well, please share the Spine project, images and the exported JSON file.

3 Likes

#10

I’ve zipped and attached the content for the Hero from the Spine examples, and included a rather bare-bones project demonstrating the issue.

Guilds.zip (557.1 KB)
hero.zip (159.0 KB)

2 Likes

#11

Thanks. We will take a look tomorrow. Holiday today in Sweden.

1 Like

#12

No worries, have a good holiday, and thanks!

0 Likes

#13

Hi!

I found the issue, sadly it’s due to a Spine 3.x feature we currently don’t support: unchecking inherit-rotation on bones. :frowning:

As you can see foot2 (and foot1) has “inherit rotation” unchecked:

It’s a very nice feature to have, especially in this case since it makes the foot keep the “floor aligned” rotation even when the leg moves.

Would you be able to progress without this feature? I can try to figure out a workaround if it is a blocker.

Sorry about this inconvenience!

3 Likes

#14

No worries, I’ll try and figure it out without this feature. So just to double check, I should ensure that Inherit Rotation on bones is checked on all bones, and then figure out some way to lock the foot bones in their current orientation?

2 Likes

#15

Yes, correct! :confused:

I thought of a workaround, I think… You should be able to make the foot have it’s own IK constraint as well, then in runtime make sure the IK target is always below the foot/on the ground. Haven’t tested it myself, but in theory it should work, albeit a bit of a hassle.

3 Likes

#16

Alrighty, thanks very much for investigating this!

1 Like