Failed compiling Android resources (1.3.0)

Hello everyone,
While trying to bundle this I got an error from Unknown Source “Failed compiling Android resources”. I tried to bundle other apps and they all get this error. I’ve tried to change the parameters in the bundling interface (like like architecture and texture compression) and it doesn’t change anything. Just in case I also tried to bundle it in release mode (which is not my goal but I wanted to see if it was related to the debug mode).

Is it a bug or is there something I might be doing wrong?

Thank you!

Sorry for the late reply. Can you please tell us more? Are you using Windows? Is it this problem you are experiencing?

No problem!

Yes I am using Windows 64bits. By the time I posted there was a small update so I downloaded it and tried to bundle dmengine and my current project for Android. Unfortunately the problem persists however I’ve got a different type of error on my current project :

  • The dmengine attempt to bundle still fails with the “failed compiling Android ressources”
  • My current project now fails with “contextResource cannot be null”, it uses the Rive dependency and nothing else really I’m just at the beginning from now.

So the post you linked down below doesn’t exactly have the same problem as I do, however as you can see there are similarities in the error message and a problem with dependencies. Also the dmengine attempt to bundle still fails the same way as before.

Could you please try again? We had some issues with the build servers.

I just tried again and still the same error “Failed compiling Android resources” with dmengine

On my main project the error message changed yet again
D:\Développement\Defold Engine - Projects\Project\build\plugins\defold-rive\plugins\lib\x86_64-win32\libRiveExt.dll (Le processus ne peut pas accéder au fichier car ce fichier est utilisé par un autre processus)

This is the message I literally got, it means “The process can’t access the file because the file is used by another process” hope it helps, might be a whole different problem.


Ah, yes, that’s another issue that should be fixed in the next Beta (coming out on monday). (pull request)
The current workaround is to bundle using bob.jar , I’m afraid (since the editor has the .dll locked)