Failed compiling Android resourses

Hi! I make a standart empty project(template) and try to bundle android version.
Bundle on Windows works fine
Windows:64 bit
I tryed a bob: with --verbose( end of screen)

I also reinstall Defold
My path has no anything chars or spaces
Its sounds like this: Failed compiling Android resources (1.3.0) - #5 by maelig.moreau ,but i dont understand how to fix that
Thanks for help!

Did you also try with Defold and your project located somewhere in your home folder?

That part of the bundle process will run aapt (android asset packing tool) on Android resources. Perhaps access to the tool (included in the Defold editor) or project files is prevented somehow by Windows or some security software.

Also, check that you have set all application icons in the Android section of game. project.

Like that right?
Also i run Defold as administrator and still get an error
What about icons?
Thats enough?

Yes, that should be enough.

Also i setup all icons in “push” fields
I dont using any security software and i set “allow” in firewall
Isn’t strange?)

What have you set as package name in the Android section of game. project?

Hmm, ok. We need to add additional logging to understand what is going on. I can prepare a custom version of bob.jar with extra logging later this week (I’m traveling today and tomorrow) and share that with you.

Oh thanks!

There’s a bob.jar with some additional loggin available for download here:

I would appreciate if you could give it a try with the same command line as before and share the output here! Thanks.

1 Like

I uploaded bob from link and swapped with the previous
the same?

mptyProject/bob.jar!/lib/' to 'C:\Users\Home\AppData\Local\Temp\1
авг. 27, 2022 3:35:49 PM com.dynamo.bob.bundle.AndroidBundler log
INFO: Compiling resources from C:\Users\Home\EmptyProject\build\default\EmptyPro
авг. 27, 2022 3:35:49 PM com.dynamo.bob.bundle.AndroidBundler log
INFO: Compiling C:\Users\Home\EmptyProject\build\default\EmptyProject\res\ to C:\Users\Home\AppData\Local\Temp\compiled_resources8823678185608
авг. 27, 2022 3:35:49 PM com.dynamo.bob.bundle.AndroidBundler log
INFO: exec: C:\Users\Home\AppData\Local\Temp\11070405446670656011\x86_64-win32\a
apt2.exe compile -o C:\Users\Home\AppData\Local\Temp\compiled_resources882367818
5608321696\ --dir C:\Users\Home\EmptyProject\build\default\Emp
авг. 27, 2022 3:35:49 PM com.dynamo.bob.bundle.AndroidBundler log
INFO: Failed compiling C:\Users\Home\AppData\Local\Temp\compiled_resources882367
8185608321696\, code: -1073741701, error:
ERROR: unspecified:-1: 'com.dynamo.bob.CompileExceptionError: Failed compiling A
ndroid resources'

Failed compiling Android resources
com.dynamo.bob.CompileExceptionError: Failed compiling Android resources
        at com.dynamo.bob.bundle.AndroidBundler.compileResources(AndroidBundler.
        at com.dynamo.bob.bundle.AndroidBundler.createAAB(
        at com.dynamo.bob.bundle.AndroidBundler.bundleApplication(AndroidBundler
        at com.dynamo.bob.Project.bundle(
        at com.dynamo.bob.Project.doBuild(
        at com.dynamo.bob.Bob.mainInternal(
        at com.dynamo.bob.Bob.main(
Caused by:
        at com.dynamo.bob.bundle.AndroidBundler.compileResources(AndroidBundler.
        ... 7 more
Warning: Failed to clean up temp directory 'C:\Users\Home\AppData\Local\Temp\110


I can’t say for sure what is failing.
One thing to note is that we only support Java 11, due to the fact that that’s what Android supports.

Also, please post text, as opposed to screenshots.
It’s very hard to read, and it isn’t searchable.
POst the t ext between triple ` and you’ll get it formatted:

some text

Edited last post
Install jdk11, still getting that error [Failed compiling Android resourses - #11 by sonytruelove]

And what happens if you run this in your command prompt?

Thanks. This shows some additional info:

  • It fails when compiling C:\Users\Home\EmptyProject\build\default\EmptyProject\res\ to C:\Users\Home\AppData\Local\Temp\compiled_resources8823678185608 321696\
  • It fails with code -1073741701. Weird code to be honest. I need to look into this.

What strikes me as strange is C:\Users\Home. Is your user really named “Home”?

Can you share your project as a zip file here?

My user is “Home” - that’s for sure
Without bob (349.8 KB)

I havent there aapt2.exe
"aapt2.exe" not recognized as an internal or external command,operable program or batch file

Yeah, it was a bit of a long shot as it’s a temporary folder that we try to delete after the process is done with it.

I’m out of ideas. There is something on your computer preventing java from running aapt2.exe from that temporary folder.