Defold Editor Not Starting in Linux


#1

I’ve downloaded Defold Editor and it’s not starting. I’m using Arch Linux and when I try to run it, it gives me this output:

radon apps/Defold-linux.gtk.x86 » ./Defold
ERROR: Resource type for extension ‘gui’ already registred (com.dynamo.cr.guied.resourcetypes.gui)
Defold:
An error has occurred. See the log file

I’ve read that this could be due to eclipse error when there’s a space in the path but:

radon apps/Defold-linux.gtk.x86 » pwd
/home/morti/apps/Defold-linux.gtk.x86

Here’s the log file: http://pastebin.com/ViZWMdX5


#2

Thanks for the report. We have other reports of this problem and are looking for a solution.

Btw, are you running 32 or 64 bit Linux?


#3

I’m running 64bit Linux


#4

Ok. We have tested mostly on 32bit and I am not sure how to get it running on a 64 bit system. I’m gonna do some tests on a 64 bit system and will let you know what happens.

EDIT: No luck with this, unfortunately. It might be 32 bit library dependencies somewhere, but chances are that it won’t work and that we need to do work to get 64 bit support. I’ll take it up with the team.


#5

hey @sicher,
i tried the linux client, and didn’t sucess too.
i am using Ubuntu Mate 14.10 64 bit ,

this is my error message on terminal :

ERROR: Resource type for extension 'gui' already registred (com.dynamo.cr.guied.resourcetypes.gui)
Defold:
An error has occurred. See the log file
/home/kotkoth/installer/defold/workspace/.metadata/.log.

and this is on .metadata/.log
http://pasted.co/b5896d77

i am very excited to try defold , looking forward !


#6

Thanks! Yes, that seems to be the error you get on 64 bit Linux. We will add support for 64 bit but I cannot say when that will be ready.


#7

a workaround for now:

I suppose to way to support 64 bit is to be able to use the 64 bit libraries mostly?
If I can help out with it somehow, please let me know

Greetings Vincent


Does not launch on Linux / Ubuntu
#8

Hi, was pretty into using this engine but ran into the same 64 bit linux limitation. Too bad.

I spent a few hours today trying to force it to work, but I couldn’t get .swt/lib/linux/x86/libswt-mozilla-gtk-3836.so to find libxpcom.so.

The architecture of the one I found in kompozer package on arch was, according to objdump -f, i386:x86_64, whereas libswt-mozilla-gtk-3836.so is simply i386. I could probably find or compile a 32 bit libxpcom.so somewhere but without libswt-mozilla-gtk-3838.so loading, the editor didn’t work.

To be honest I’m not much of an expert at java and multilib stuff so the solution might be there somewhere, but I have to give up on defold for now. (at least until 64bit linux support… plans for that?)


#9

There are definitely plans for 64 bit support, but I have no good ETA yet.


#10

yes, I learned later that it does not work too and gave up for now because it is on the list to be fixed. Apologies for not updating the the thread.
Let’s hope it will be rather sooner than later :smile:


#11

Download xulrunner from here:
https://ftp.mozilla.org/pub/xulrunner/releases/3.6.28/runtimes/
And unpack somewhere

Add this lines to Defold.ini
-Dorg.eclipse.swt.browser.DefaultType=mozilla -Dorg.eclipse.swt.browser.XULRunnerPath=<path to xulrunner directory>
To fix git integration:
sudo apt-get install libssl0.9.8


#12

And this enabled you to run Defold on Linux?


[Linux] Open Project doesn't work (SOLVED)
#13

yes, it helped me to run defold editor on linux mint (32 bit)


#14

Nice, thanks for sharing!


#15

it does not work for me, the editor starts but any action seems not working with the error tab showing some null loop stuff.
there is also no libssl0.9.8 package on Ubuntu 15.10.


#16

I posted som updates on this topic in another thread.


#17

I can start editor but getting the same error if I start editor from the command line. But i’m running editor on MacOS El Capitan


#18

Would you mind creating a new forum topic since your issue isn’t related to running the editor on Linux?


#19

NOT work in Ubuntu 64 :sob::sob::sob:


#20

Do you get an error message or anything else that hints at what’s wrong? It should work on Ubuntu.