Defold Editor Not Starting in Linux


#21

What does it say if you run it from the terminal?


#22

What version of Ubuntu are you running??
Our minimum supported Ubuntu version is now 16.04 (see release notes)


#23

log0file.zip (83.7 KB)

my os ubuntu 16.04 LTS 64-bit

please see attached file log0file.zip


#24

Hmm, I’m not sure why it behaves like that. Is this directly when you start the editor?

After some googling on your error, “org.eclipse.swt.SWTError: No more handles [gtk_init_check() failed]”, there are a few ideas:

  • The callstack suggests that you are having problems with the gtk package.
    What version of gtk do you have? (dpkg -l libgtk[0-9]* | grep ^i)

  • It could be related to your X server. Running as root could cause issues

  • It could be IPV6 related


I’ve tried to use root, and disable Ipv6, but It still ran for me :confused:


#25

I downloaded the Defold editor 1 on our Fedora and tested to open the file defold-linux.sh and nothing happening! Is i opening wrong file?:grinning:


#26

And in Editor 2 is the building function not working!
Before:


After:


#27

There’s a progressbar bottom right in your last screenshot, at 73%. Doesn’t it reach 100%? And the status bottom left mentions that it writing files to disk. It looks like the builds are working, but I assume something goes wrong?


#29

How is this related to Defold or the problem you’re having?


#30

sorry i was new and my dad said it to me after it :disappointed_relieved: