[Linux] Open Project doesn't work (SOLVED)


I just installed the Defold editor on Linux. It opens right but when I press the menu option [File > Open Project] it doesn’t do anything.

In the Workspace Log I have: Unhandled event loop exception

I checked on the FAQ and it appears I have all the dependencies.

My linux is Linux Mint 17.3 Rosa x86_64

Luis Cabellos

The Linux support is for 32 bit but 64 bit is in the pipeline.

Thanks for the info.

There’s a thread on getting Defold to run on 32 bit Linux here: Defold Editor Not Starting in Linux

Temporary fix though! As @sicher said 64 bit Linux support is on the roadmap.

I posted an update on this topic in another thread.


We have 64bit support now.

I’ve just got the 64 bit version on Fedora and I’m having the same issue.

Hmm, @jakob.pogulis, any idea?

Could you try launching the editor by running the script Defold-linux.sh instead of executing the binary?

@jakob.pogulis That fixed the errors on load and I can login and see my projects. However, I’m now getting an error when creating a new branch.

com.dynamo.cr.client.RepositoryException: Unable to create branch
at com.dynamo.cr.client.LocalProjectClient.createBranch(LocalProjectClient.java:101)
at com.dynamo.cr.editor.wizards.ConnectionWizardBranchPagePresenter$CreateBranchRunnable.run(ConnectionWizardBranchPagePresenter.java:70)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)

Caused by: com.dynamo.server.dgit.GitException: /opt/Defold/plugins/com.dynamo.cr.dgit_1.0.0.201612191732/git/x86_64-linux//bin/git: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory

at com.dynamo.server.dgit.CGit.checkResult(CGit.java:105)
at com.dynamo.server.dgit.CGit.checkResult(CGit.java:100)
at com.dynamo.server.dgit.CGit.cloneRepo(CGit.java:149)
at com.dynamo.cr.branchrepo.BranchRepository.createBranch(BranchRepository.java:120)
at com.dynamo.cr.client.LocalProjectClient.createBranch(LocalProjectClient.java:99)
… 2 more

Maybe this could help?


That fixed it, thanks

1 Like