Can you dev with Defold on a Chromebook?

#1

Hi everyone,

Self explanatory question :slight_smile:

I’m looking into a cheap solution for developing on the go, and the attractiveness of Chromebooks prices make me wonder if it’s possible to use Defold “somehow” on these?

Thanks in advance,

K

2 Likes

#2

I would say, yes soon.

http://www.omgchrome.com/run-windows-software-chromebook-crossover-android/

To quote

“We have DirectX 9 support, keyboard support, mouse support, and sound support today! People, we are staring at a Leprechaun riding on the back of a Unicorn while taking a picture of a UFO. We are running CrossOver through Android on a ChromeBook running a Windows based game launched from the Steam client.”

4 Likes

#3

I suppose you could install a lightweight Linux distribution (anything with xfce, lxde or similar DEs) and run Defold on that :slight_smile: Just make sure it has an Intel CPU (AMD CPU support is mediocre at best) and steer clear of ARM-based Chromebooks if they still make those (?)

3 Likes

#4

@britzl may have some input here, as there’s a Chromebook on his desk =]

2 Likes

#5

I used it to test that Android apps run well. Blossom worked flawlessly, as did some other Defold created games! I haven’t looked into doing any actual dev work on it.

2 Likes

#6

@kgoya coincidentally I spent about a year or so using a Chromebook (Acer C710) as my primary dev machine; my experience was surprisingly not that bad. If I were you I’d look into installing Crouton, which’ll let you use Ubuntu in a chroot. From there you should be able to use just about any linux dev tool, the Defold Editor included. If you opt to install Crouton, feel free to send any questions / bizarre errors my way!

6 Likes

#7

this is how i run defold on my chromebook (1-2min)

7 Likes

#8

What kind of performance do you get in the editor? Can you actually work reasonably well on the Chromebook or is it all very sluggish?

0 Likes

#9

So… I use an Acer 11 Chromebook and have tried execute the Defold file, but it won’t work, so will I have to use an older version for it to work?

0 Likes

#10

What is the error you’re getting?

0 Likes

#11

It’s not an error message, all it tells me is that Defold is a directory and just does nothing else.

Here’s what I did:
$ cd Defold
$ ./Defold
Then I tried Chmod and executing it
$ chmod +x ./Defold
$ ./Defold

and it still said the same thing bash- Defold is a directory.

0 Likes

#12

Which version did you download? What kind of CPU does the Chromebook have?

0 Likes

#13

I downloaded the lastest version and my CPU is Intel Celeron N2840 / 2.16 GHz

0 Likes

#14

For Linux?

0 Likes

#15

Yes and I followed the Linux instructions.

0 Likes

#16

Ok, double checking: could it actually be a directory? Did you try

cd Defold
ls

0 Likes

#17

Here are the steps I use to run Defold within Linux Beta on ChromiumOS:

So if you have the Defold folder (not the zip) in your Linux Beta folder you can try the following:

1.) So in my Linux folder I have a folder for Defold. First let’s cd to where we can launch the software:

cd ./Defold
./Defold

Now we get the following error:

-bash ./Defold: Permission Denied

2.) Lets set the permissions:

chmod u+x Defold
./Defold

We get an error saying:

Failed to launch application

3.) Lets Chmod the jdk

cd ./packages
chmod  u+x jdk11.0.1/bin/*
cd
cd ./Defold

4.) Let’s try to run the application:

./Defold
0 Likes

#18

Oh, we could probably add the executable flag when packaging the editor for Linux. And everything works after you do this?

0 Likes