"bleeding pixels" in models with low-res textures

I have this model in defold and blender:

The problem is what is these extra pixels on the textures of the meshes? the terrain of grass is composed of various squares, each has its texture mapped to a tileset i have here, but why is it mapping extra pixels from other tiles? Ppl in the discord server guided me to create make the mapping pixels away from the borders of the tiles, it works but i cant do that consistently across all sqaures and alike, id have to manually set each map of each square. How can i solve this?
heres an image of me trying to make the mapping a bit smaller to create a gap between the map and the borders of the tiles:

Are you using nearest filtering for the sampler in the material?

Yes. I temporeraly solved the problem by adding the gap between the mapping and the borders. Not a great solution but a solution indeed. Tho im worried all my textures are now 30x30…

Hello there, I don’t know if I understood correctly but it could a problem I had, too when baking.

under the baking settings in Blender, there is a tab where you can set the margins and, more importantly, the type of the margin.
Adjust faces does what you describe, takes pixels from neighbouring faces and can lead to these odd pixels from other faces:
Screenshot 2022-10-04 at 07.53.37
You need to set the type to extend (and choose whichever size you’d like to have):
Screenshot 2022-10-04 at 07.54.07

Screenshot 2022-10-04 at 07.54.36

But I noticed as well, that even with a margin set to 0 px and no gaps between the islands, there is bleed:

So, I usually unwrap with a gap, set the margin type to extend and then play with the margins until I get what I like.

this doesn’t seem to be your problem at all. Sorry!
But looking at your images and the uv map: did you check whether the tree is unwrapped properly? There is this pentagon on the tile with the leaves that makes me a bit suspicious. And/or have you done a different unwrap in Blender but not exported the mesh again?

1 Like

Looks like you did fix the “bleed” problem. Now I believe what we are seeing may be due to bilinear or trilinear filtering at oblique viewing angles which also causes the blurriness in the textures . In defold 1.3.6 anisotropic filtering support was added for material samplers which should help but is platform specific. Wonder if mipmaps may also be an issue here.

One thing to verify, what are the WrapU/WrapV moved in Blender?
You have it as “Repeat”, which will affect how the sampling will behave at the borders of the texture.
Try with “Clamp” instead to see if that makes a difference.