The enabled property can be changed via gui.set_enabled, like any other property, but instead of using gui.get_enabled to get its value, instead gui.is_enabled is used. Why? Is it just kept this way for backwards compatibility? Why not add gui.get_enabled as a synonym for gui.is_enabled?
sorry, probably should have put this under feature requests
Someone decided that is_enabled() was better than get_enabled(), but we are a bit inconsistent in our choice of name since we use get_enabled
for some other APIs. We will not add both as it will add binary size to the engine.
2 Likes
gui.is_enabled is likely kept for consistency with boolean checks in the API. Adding gui.get_enabled could be redundant.