White screen before building

The first thing they would point out is that we use an old version of GLFW :slight_smile:

But you have a point, I’m pretty sure there’s something we can do to use the clear color set in game.project immediately when we start (I thought we did this already)

Color is read here on engine init:

But we open the window earlier:

Perhaps we can pass in a clear color when the window is opened?


Which part of the engine should I paste these codes into? Thanks! Btw I want to ask if other users using the engine on Windows have ever experienced this behavior too…

What I shared was some of the engine source code. It’s not something to put in your game. But it is the place where one might find a solution.

For OpenGL, Vulkan has one too.

https://www.glfw.org/GLFWUsersGuide273.pdf Newer but still lists the function.

Doesn’t look like a clear function is called right after opening the window for OpenGL or Vulkan, but I think it could be?

glClearColor(0, 0, 0, 1); – color from game.project ?

builtin clear

1 Like

I wasn’t going to use it, but should I use an extension? I’ve never seen this kind of behavior on other programs. Or should I just ignore it?

No it needs to be fixed in the engine!

Is there a ticket for this or do you need one?

It is this one: https://github.com/defold/defold/issues/5419

1 Like

I think you’ve already told me the solution, but I don’t think I understood it. Sorry, but can you please explain it to me one more time? :anguished:

To solve this issue we need to make a change to the engine on when it starts to ensure that the color is set earlier than it is done today.


Is there anyone who solved the same problem?:joy:

Of course, the color is also a problem, but the problem is the window that turns off and opens again.

I don’t know if it’ll help, but I’m attaching a video. It glistens and runs in startup like this. Also at the moment of glitter, I can’t see the engine logo on the task bar.

1 Like

And this is taskbar…

1 Like

These are the logs I got from building…

I just wanted to ignore these, but it’s so annoying…

The logs look just fine.

You’ll have to wait until someone fixes the problem in the Win32 build of the engine.

1 Like

In fact, this appears not only in Windows build but also in Android build.

I don’t think this will be solved quickly. But I’ll wait for someone and continue working. :slightly_smiling_face:

Thanks to the kind people in the forum, I could still remain. I hope this problem will be resolved soon. Thanks for helping me again! :blush:

1 Like