Unknown source: Syntax error in file name, folder name, or volume label (Solved)

#1

Hi. I tried to bundle my project and got this message “Unknown source: Syntax error in file name, folder name, or volume label”. It first happened yesterday on latest update of 1.2.175. On 1.2.176 this error continues. Also this message: Syntax error in file name, folder name, or volume label are shown for me in russian, as my system language is russian. But funny part is that the same project on 1.2.175 (but not the latest version) on my Mac bundles project ok. Both times it was Windows 64-bit debug version. As error suggest it must some kinda name error. I checked recently changed files but everything looks ok.

For what should i look to fix this error? Maybe to clean some folders? Other project bundles fine on 1.2.175 and 1.2.176.

Here is the bundle log file.
log.txt (24.7 KB)

1 Like

#2

Hi!
At what version did it work last time?

The log file you sent is the C++ log file from the build server. What we’re seeing here is something else related to bob.

My guess is that there’s a /or \ mismatch somewhere, or perhaps even an upper/lower case issue.

It’s difficult to tell exactly what the problem is. I suggest you create a minimal repro case for us, so we can pinpoint the root cause.

0 Likes

#3

Was working
1.2.175 on windows, but it was a week a go.
1.2.175 on mac today
Editor: eb31ede76a85f9e7dd669c001f4b5d0aa4e2787a
Engine: e41438cca6cc1550d4a0131b8fc3858c2a4097f1

That was a log file from build folder. Are there any log files related to bundling process? Cause in regular defold log file i can’t find any information related to bundling.

I will try to create a repo, but it will take some time. And mostly i do not understand why it builds on mac, but not on windows.

0 Likes

#4

Thanks. We need to narrow down the cause of this. I suggest starting with an empty project, adding the native extensions you have one by one and bundle for Windows every time.

0 Likes

#5

I don’t think it has anything to do with native extensions @britzl, since the log.txt contains no actual errors (the build worked).

0 Likes

#6

Well. I have found imposter. Do not include in your project name : . At least when developing on windows. :expressionless: I think it can’t create folder with : for some reason.

1 Like

#7

Good point!

Oh, yes, that’s a problem!

I recall this being a problem in the past as well. @JCash I wonder if we could URLEncode the project name before using it as part of a file path?

0 Likes

#8

And i suppose it’s just windows) On mac it replace : with / automatically if i recall correctly.

win

File name can’t contain these characters

0 Likes

#9

We already clean the name for some purposes. The question is in which case are we not using the cleaned up version.

0 Likes