Unable to install iOS app to my phone via Xcode and free dev account (Solved)


Hi guys. So i followed the guide about developing for ios and got my provision profile and free dev account. I successfully run test application from Xcode and granted permission in general settings in my phone. After that i build a simple mobile game (default project) in Defold and tried to send it to my iphone via Xcode/Devices and got an error “Unable to install”.

Build settings:

Xcode error

I also tried via command line (ios-deploy) and got this error “error 0xe8008001: An unknown error has occurred. AMDeviceSecureInstallApplication(0, device, url, options, install_callback, 0)”.

Am i missing something? Do i need to have app name same in test app in Xcode and in Defold? Provision profile was created yesterday, so it should be valid.

Xcode 12.0.1
Defold 1.2.174
masOS Catalina 10.15.7
iOS 14.0.1
Iphone SE 2gen



I feel you. These kinds of problems are usually pretty frustrating to figure. It is very likely a provisioning profile problem or something like that.

Did you uninstall the test application from your device before testing to install the Defold app you built?

1 Like


I think you need to have the same bundle id, yes. (e.g. com.mycompany.myapp)

1 Like


Yep, that worked. I don’t know why i didn’t check it before.



I tried several times and it didn’t worked. The problem was in bundle id, it wasn’t set correctly in Defold




I got the same problem and this topic helps me a lot ! Perhaps, the documentation located here https://defold.com/manuals/ios/ needs to be completed about the constraint of the identical bundle ids…

1 Like


I agree



Good point. I’ve added a note about this in the manual.

For future reference: The documentation is open source and available here: https://github.com/defold/doc

We happily accept pull requests!