"Unable to delete file" error while Bundle Android Application

#1

I have downloaded the latest Defold version 1.2.173.

While compiling to android application i am getting error “Unable to delete file: D:\Users\Shettigar-PC\Music\armv7-android\armv7-android\Mobile game\aab\base\resources.pb”.

Tried compiling with new project, even than getting error. Screenshot of the error below and also attached the incomplete complied resource.


armv7-android.zip (6.4 MB)

2 Likes

#2

I have the same issue

0 Likes

#3

@dilipkumar.lankey and @vsshettigar please see this announcement: Problem bundling APK/AAB file from editor in 1.2.173

0 Likes

#4

Tried Alpha version : 1.2.174 for Android APK Compiling. Getting error message “Cannot run program “D:\Users\Shettigar-PC\Downloads\Defold-x86_64-win32_174_alpha\Defold\packages\jdk11.0.1\bin\jarsigner”: CreateProcess error=2, The system cannot find the file specified”


image

0 Likes

#5

If you look in “D:\Users\Shettigar-PC\Downloads\Defold-x86_64-win32_174_alpha\Defold\packages\jdk11.0.1\bin”, is there a file named jarsigner ?
Or is it perhaps called something else?

0 Likes

#6

I have Updated from Alpha Version 1.2.174 2e31dcc to d5b27d, at that time it did not include the jarsigner.
Then I downloaded the new alpha version from d.defold.com\alpha it had the jarsigner .

Tried to compile with alpha version . getting Module not found error.

1 Like

#7

I was getting the same. If you download OpenJDK 11 and extract that to Defold/packages and rename the folder to match the existing folder name it should fix it.

3 Likes

#8

Thanks @Epitaph64 . Replacing OpenJDK worked for Alpha version :smiley:

1 Like

Improved level load performance using OpenJDK 15
#9

:100: Yay for the alpha fix, the Defold team is amazing! Helpful post, and quick solution!

I also like the new ‘oneFileNeeded.keystore’ signing… looks like Android is taking leaps compared to stuck in ‘cyber-beaurocracy’ iOS abides to. :smirk:

Hopefully the update to 1.2.174 will be seamless!

0 Likes

#10

Note that the latest alpha version (sha1: 1ad8b419bbccf27994e3290e6c6ede2594397800) shouldn’t need this fix since we now properly package jarsigner and required mods.

1 Like