Unable to build probably due to missing Vulkan library


I came to ask about an issue my team recently encountered. While trying to build a project in the new 1.7.1 version of Defold, the editor gets stuck on “fetching engine” step and after a while I get the following error:

I think it’s largely because of the fact we are trying to use the Rive integration, however the issue is that for another person in our team, it works without any problem, while I tried on two different machines, getting the very same error. Moreover I tried to the best of my ability to find similar issues, but to no avail. It seems like I may actually be missing the library, but I can’t really find it as well. Plus lastly removing dependency with the lua server results in no change to the issue.

Very grateful for any help!

1 Like

That person must be using the latest alpha right? We removed the experimental library yesterday, so I’d use a slightly older version or remove the experimental part in the manifests and try again.


I was using the latest alpha and my colleague was using an older version. After removing the experimental part new errors appeared :d But I moved to an older version and we returned to the experimental in the manifest, it works now. Thank you for the help!

We’ll make sure everything is in sync for the next stable version, thank you!