Test this for science

#1

FrameLagTest.zip (1.8 KB)

Let this run without touching it for like 5-10 minutes. Post a screenshot of any spikes in frame time without touching it (resizing / minimizing will add frametime too so don’t touch the window). Post your computer specs too.

Example

If you get consistent ~16 with absolutely no major spikes please post to say that too with screenshot of highest spike you did get and specs.

0 Likes

#2

Ran for a little over 5 minutes and got no spike, this is the peak frame;

Running in a macbook pro from 2015-isch. A single external monitor connected. Had the benchmark running while compiling code, running other instances of defold, using chrome/slack etc.

Have you tried closing all other applications while running the test? Especially Fraps or other benchmarking software which might potentially interfere.

2 Likes

#3

My CPUs were all well below 10%. I don’t see any reason why there should be spikes.

I’m testing on Win10. i7 920. GTX 1060.

I’ll test closing absolutely everything including Defold editor. Make a debug build. Also set AV to gaming mode so it should not interfere.

0 Likes

#4

This is my results:

Processor: Inter® Core™ i7 CPU Q740 @ 1.73GHz
Windows 10

1 Like

#5

Tests with nothing running that isn’t crucial. AV set to gaming mode. My CPU is kind of old now but it still shouldn’t be a problem, other non-Defold games doesn’t seem to have similar lag spike issues. Especially with such a simple example this shouldn’t happen.

When I open a web browser there is a spike.

While leaving open while YouTube video plays.

Main problem with these spikes is it can let big dt spikes happen which can let object teleport through physics geometry too easily. But they are also noticeable and annoying. And if set display settings to

vsync = 1
update_frequency = 60

The vsync issues show up with the game running super fast on lots of people’s computers. Even happens in HTML5 builds.

1 Like

#6


Processor: Intel© Core™ i5-8250U CPU @ 1.60GHz × 4
Graphics: Intel Corporation UHD Graphics 620
RAM: 7.7 GiB 2400MHz, DDR4;

I’ve had Firefox open with 3 tabs >.<

2 Likes

#7

Running for like 10-15 minutes on top of everything else

Running it a second time and got a peak right away

After one minute this dropped and it stayed this way for around 5 minutes

I’m running chrome with three tabs open, Spotify, Trello, Wunderlist and one instance of Defold.

MacBook Pro (Retina, 13-inch, Early 2015)
Version: 10.14.4 (18E226)
Videocard: Intel Iris Graphics 6100 1536 MB
Memory: 8 GB 1867 MHz DDR3
Defold version: Latest Alpha of 1.2.50
I’m using an external monitor.

2 Likes

#8

Away from the computer for half an hour. Have a lot of softwares open. Firefox with (10+ tabs - including paused youtube), text editors, quicktime, sourcetree, photoshop, golang, pycharm, discord, slack, onenote, open office and a few more.

Tried to resize the window and it stayed at 16.113 - Only thing that made it go up was (full screen) maximising the window.


Same software as above but I opened a 4 new youtube tabs and starting playing them as well as other tabs.


Defold channel editor-alpha
Defold editor sha 32bed942610e57c62b906627bdec4845f354392f
Defold engine sha 34bb9603dfcb145c74fbb4f36f4146acea4c4252
Defold version 1.2.149
GPU AMD Radeon Pro 560 OpenGL Engine
GPU Driver 2.1 ATI-1.60.26
Java version 11.0.1+13
OS arch x86_64
OS name Mac OS X
OS version 10.13.3

33

Computer is a laptop with a two external displays, a Mac one and a normal Dell.

2 Likes

#9

Spec:

Operating System
Windows 10 Pro 64-bit
CPU
Intel Core i7 6600U @ 2.50GHz 41 °C
Skylake-U/Y 14nm Technology
RAM
16.0GB Dual-Channel DDR3 @ 798MHz (11-11-11-28)
Motherboard
LENOVO 20EV000YUK (U3E1)
Graphics
Generic PnP Monitor (1920x1080@60Hz)
LG FULL HD (1920x1080@60Hz)
Intel HD Graphics 520 (Lenovo)
2048MB ATI AMD Radeon R7 M370 (Lenovo) 42 °C
CrossFire Disabled
Storage
465GB Western Digital WDC WDS500G2B0A-00SM50 (SATA (SSD)) 31 °C

2 Likes

#10

CPU

AMD Ryzen 7 1700 Eight-Core Processor, 3000 Mhz, 8 Core(s), 16 Logical Processor(s)

RAM

16 GB DDR4

GPU

Nvidia GTX 1050 TI

Storage

Samsung SSD 970 EVO 1TB

2 Likes

#11

FrameLagTest2.zip (2.4 KB)

Here is an updated test with an appmanifest included to remove Physics2D,Physics3D,Record,Facebook,Gameroom

Please test again like before.
For me I tested it 10 minutes with photoshop open, a bunch of Chrome tabs open including reddit and twitter, twitch playing, editor open, and peak was only 16.700.

By the way the console still says

ERROR:GAMESYS: Could not retrieve the physics socket ‘@physics’: -6.

when excluding physics on a blank project.

Please test version 1 again if you test version 2 just let them run on a device without touching them for at least 5 minutes. I tested version 1 again now and max peak frame was 16.718 ¯\(ツ)/¯ This was in same testing situation with a lot of stuff open doing things. Although I think this is a new engine version I’m testing on now too.

Both cases peak was Engine.Frame and below that Profile.Draw so at least right now probably only the profiler contributing to higher peaks and with it excluded too may have no similar peaks on an almost blank project under reasonably normal user situations?

More data may help excluding potential issues!

2019-04-20%2014_55_28-About

2 Likes

#12

FrameLagTest1

No Errors

FrameLagTest2

ERROR:GAMESYS: Could not retrieve the physics socket ‘@physics’: -6.

Environment
Waterfox opened 9 times each with anywhere from 5-30 tabs including a bunch of paused youtube videos
My own defold project I was working on and building constantly to check things
Affinity Designer

I ran each for around 10-15 mins open in the background and then only opened once to screenshot at the end.

PC Specs
OS
Windows 10 pro 64-bit
CPU
Intel Core i9-9900k @ 3.60GHz
RAM
32GB DDR4@3200MHz
Motherboard
Gigabyte Z390 Aorus Pro WIFI
GPU
Nvidia RTX 2080
Storage
Samsung 970 EVO Plus NVMe SSD 1TB
Monitor
Asus 1920x1080@144hz

1 Like

#13

Test#1 on my Notebook (PC will follow soon), ran 40 mins:
notebook_test1_about


Short Specs:
Intel Core i5-8250U, 16GB RAM, 512GB SSD, Intel UHD Graphics
( I could run it with the Geforce MX150 as well, have to compile it first)

1 Like

#14

Same device with FragLameTest2:

CPU Load peaks every 2 seconds (seems to be just 1 core) from 8% to 14%. Seems like its core 4 at the graphic.

1 Like

#15

Test with my game-pc:

Test%201%20-%20GamePC%20-about
FrameLagTest 1:


FrameLagTest 2:

Specs:
Intel core i7-3770, 16GB, 1,5TB SSD, Nvidia GTX-1070AMP

1 Like