Sound problem under 1.2.181

A few months ago I made a simple html game. The sound worked in both android and ios mobile browsers. Now, when I prepare the same game in version 1.2.181 - sound does not work on IOS (Safari and Chromium).

When I try to compile game in older version 1.2.165 I get error for all used sounds /main/main.collection
The file ‘null’ could not be loaded.

What is the problem ?

So no sound at all? Wav or ogg files? Can you share a minimal repro case?

We added a loop count option to sounds and this has modified your .sound and .collection files. If you remove the loop count entries from the files (version control or using text editor) you will be able to open them in an older editor again.

There are no sounds at all. I have now tested this on another simple example. I am using the ogg format.
Old compilations give sound on IOS (chrome and safari) but new compilations don’t

That sounds odd. If it was a general issue that it isn’t working on iOS, I would have expected a lot more reports about it. So I’m guessing its something a bit more nuanced.

Would you mind sharing your small test project with us?
You can zip the project folder (exclude the ./build and ./.git folders) and upload here or share with us in a PM.

Of course. Here - a simple example (376.6 KB)

1 Like

@Mathias_Westerdahl Do you have any information about this problem ?

1 Like

Not yet I’m afraid. I hope to be able to look into this today.
(And thanks for the test project!)

1 Like

BTW, it took me over 2 years to start working with Defold :slight_smile:
A few months ago I found some time and made my first game. Defold is a really great tool, I got my developers interested in it. Congratulations guys !


Thank you for the encouraging words!


@Mathias_Westerdahl what is the deal with this task ? I need it urgently :frowning:

The deal is that we have many tasks to do, and we try to prioritize them best as we can.
Like I said, I hoped to look into it this friday, but I got caught up with other tasks.

I have now tried it on iOS, both native and in an iOS browser (Safari and Firefox), and the app plays the sound. I use the 1.2.181 editor to bundle the app.

1 Like

Sure, I understand that. Thank you for the information.
Did you run my example or did you do your test ?

I ran your example.

1 Like

it is strange. Thank you very much.
I’ll run Defold on another computer and check it. It cannot be a problem with my phone as there is sound in the old version. I will let you know when I find the cause

While we do try to help everyone in a timely fashion I’d like to point out a few things:

The first thing I’d like to point out is that Defold is a completely free to use product for you as a developer. We charge you nothing and we don’t ask for a rev share on your games or sell you costly licenses.

The second thing is that we’re a small three-man team working full time on Defold. We need to maintain laser focus to be efficient and deliver new features and bugfixes in every release. In order to do so we plan our daily work in batches of four weeks at a time. We try to not diverge too much from our plan but if we get reports from multiple developers about crashes we obviously give these priority.

Third, the work we do tries to follow the roadmap we set up at the beginning of the year. The roadmap is influenced by feedback from our users, from platform providers and from our corporate partners. The corporate partners are our paying customers and the only reason we can give away Defold for free. The corporate partners can influence our roadmap and we work closely with our partners to build value for them and for Defold in general. If want to more directly influence our daily work you can sign up as a community sponsor or a corporate partner:


I understand ! Thank you

I did the same and tested on an iPhone running iOS 14 something and heard a sound when pressing the red box in your test app.