Sad face icon in iframe on raspberry pi


I’m getting this sad face whenever I load a HTML5 game on my raspberry pi. I am sure it is not related to defold, but, I wanted to ask where this face comes from, if it might be solved by upgrading the raspberry pi, and generally, what is the best way to get a Defold game running on a raspberry pi.

I believe there is a problem with the Linux builds that are not compatible with raspberry pi, but I can quite remember what it is. Is this still true? I would assume HTML5 and chromium browser is the easiest way? If I create a HTML5 bundle, can I host it locally (and if so, how do I open it?)

(And yes, @ross.grams, I am still playing rabid robots)

1 Like

HAH! Nice! I feel famous.

Sadly I don’t know anything about the Raspberry Pi though. Is it possible to use the inspector in the browser to look at the sad-face-icon? Maybe find some clue as to what it is? [Edit] Hmm, I guess it’s some variation of chrome’s crash icon.

I think it’s the Chromium crash face, which is google’s lite browser (I believe).

Mostly it would be nice to know if updating my raspberry pi is likely to solve this problem or not. My current pi has the following characteristics.

Broadcom BCM2837, Cortex-A53 (ARMv8) 64-bit SoC
1,2 GHz
VideoCore IV 400 MHz
IEEE 802.11.b/g/n
Bluetooth 4.1
Fast Ethernet 10/100 Gbps

They seem pretty out of date to me, and performance is very very slow generally, but I don’t want to update unless I am (fairly) confident I’ll be able to run a HTML5 defold game in Chromium.

I’m sure that the iframe with the game crashed because it tried to allocate too much RAM. By default, any Defold game allocates 256MB, and you can change that via the game.project setting:

Open to check if it supports WebGL. If not, you will see “SwiftShader” (the slow software renderer) in the Unmasked Renderer field and any Defold game will run super-slow on your RPi model.


This is a really great response with very useful information. THANK YOU


In case anyone is reading this from the future, the easiest way to get a Defold game onto Raspberry Pi is by using an android OS- I’d recommend lineageOS. Gamepads don’t work out of the box, but everything else goes.

1 Like

Android OS on a Raspberry Pi seems a bit hacky, did you ever find out why it didn’t work in the first place? Did your Rpi give too little RAM by default to chromium or was it an OS issue of compatibility? Once I get home in a few months I can test on the newer Rpi model with extra RAM if it’d be of any use.

I did get a HTML5 app running on the pi with more RAM (worked fine) but my pi isn’t attached to a keyboard or a mouse or a touchscreen, nor can I guarantee I will always have internet access. On lineageOS, I can boot and run the app only using one button on the custom controller. It’s an Arm86 chip, which lineageos was designed for, so it’s fine.

1 Like