Running Linux Defold On openSUSE Tumbleweed KDE 64Bit Linux?

#1

Hi,

Our development team is now using openSUSE Tumbleweed KDE 64Bit Linux.
We can run Linux Defold and open an existing Defold project.
Problem is when we try to [Build] Defold project: it crashes Defold Linux editor?

The log file is attached.
Any ideas on how to make Linux Defold work with openSUSE KDE?
Let us know, thanks!

Jesse

hs_err_pid27862.zip (28.4 KB)

0 Likes

#2

Not sure why it wouldn’t work there.
Our supported platform is Ubuntu 18. Perhaps there are differences in how your linux flavor loads shared libraries?

The relevant part of the log is this:
(-Ddefold.version=1.2.170 -Ddefold.editor.sha1=c907611b80aaec1c2bd1f4490699c0be3b250f87 -Ddefold.engine.sha1=5791ee6d96b87e50eee5acd70abaa4026fefef28)

Stack: [0x00007f164e05a000,0x00007f164e15b000],  sp=0x00007f164e157e00,  free space=1015k
Native frames: (J=compiled Java code, A=aot compiled Java code, j=interpreted, Vv=VM code, C=native code)
C  [jna8238631516295956040.tmp+0x7604]
C  [libffi.so.8+0x7001]
C  [libffi.so.8+0x75c0]
j  editor.texture.engine$webp_compress_rgba_buffer.invokeStatic(Ljava/lang/Object;JJJ)Ljava/lang/Object;+319
j  editor.pipeline.font_gen$compress$fn__58568.invoke(Ljava/lang/Object;)Ljava/lang/Object;+282
J 5087 c2 clojure.core$map$fn__5851.invoke()Ljava/lang/Object; (209 bytes) @ 0x00007f16f2f6d4ac [

It’s apparently failing to call the texture compiler (which is a shared library).

If you download an unpack the bob.jar, and check the dependencies, what does it say on your machine?

$ mkdir foo
$ cd foo
$ wget http://d.defold.com/archive/5791ee6d96b87e50eee5acd70abaa4026fefef28/bob/bob.jar
$ unzip bob.jar
$ ldd ./lib/x86_64-linux/libtexc_shared.so
	linux-vdso.so.1 (0x00007ffc470f2000)
	libPVRTexLib.so => not found
	libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f4c48d66000)
	libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f4c489dd000)
	libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f4c4863f000)
	libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f4c4824e000)
	/lib64/ld-linux-x86-64.so.2 (0x00007f4c49226000)
	libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f4c48036000)

$ ldd ./lib/x86_64-linux/libPVRTexLib.so 
	linux-vdso.so.1 (0x00007fff5adf4000)
	libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007fc05c402000)
	libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fc05c064000)
	libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007fc05be4c000)
	libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fc05ba5b000)
	/lib64/ld-linux-x86-64.so.2 (0x00007fc05ccef000)
0 Likes

#3

Hi,

Output is below:

jlp@SortaFastDesktop:~/foo> su
Password: 
SortaFastDesktop:/home/jlp/foo # ldd ./lib/x86_64-linux/libtexc_shared.so
ldd: warning: you do not have execution permission for `./lib/x86_64-linux/libtexc_shared.so'
linux-vdso.so.1 (0x00007ffc1437d000)
libPVRTexLib.so => not found
libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fe87e3d4000)
libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007fe87e1fe000)
libm.so.6 => /lib64/libm.so.6 (0x00007fe87e0b9000)
libc.so.6 => /lib64/libc.so.6 (0x00007fe87def2000)
/lib64/ld-linux-x86-64.so.2 (0x00007fe87e6c6000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007fe87ded8000)
SortaFastDesktop:/home/jlp/foo # ldd ./lib/x86_64-linux/libPVRTexLib.so
ldd: warning: you do not have execution permission for `./lib/x86_64-linux/libPVRTexLib.so'
linux-vdso.so.1 (0x00007ffcc4de2000)
libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f7eb0569000)
libm.so.6 => /lib64/libm.so.6 (0x00007f7eb0424000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f7eb040a000)
libc.so.6 => /lib64/libc.so.6 (0x00007f7eb0243000)
/lib64/ld-linux-x86-64.so.2 (0x00007f7eb0cd2000)
SortaFastDesktop:/home/jlp/foo #
0 Likes

#4

Ok, there doesn’t appear to be any missing dependencies as far as I can tell.

The message:

ldd: warning: you do not have execution permission for `./lib/x86_64-linux/libtexc_shared.so'

Is that an issue on your linux? Does it have to be executable to be loaded properly by ffi?

0 Likes

#5

Hi,

Sorry, confused…

What is “loaded properly by ffi?” ?
Hoping we can fix this, want to get into some new game dev with Defold soon!

Jesse

0 Likes

#6

Guess running Defold on openSUSE Tumbleweed KDE 64Bit Linux is not an option…
I will run Defold on a Windows 10 Pro 64bit desktop that I VNC into from my Linux desktop.

Thanks!

Jesse

1 Like