Project Build Error - System cannot find specified file

I’m very new to using Defold, and I am using this engine to make a game for a school assignment. Every time I try to build the game I get this error for both /builtins/render/default.render_script and /main/test.script (I made this one to try out some code):

Cannot run program “C:\Users\orawe\AppData\Local\Temp\defold-unpack-7e5c022ee89d625257f3e22797f49b51d60ba2ef10889163379200209861/x86_64-win32/bin/luajit-32”: CreateProcess error=2, The system cannot find the file specified

I have even tried to run the game with Debug, but it gave me the same error but with more than just those two scripts. All of the tutorials I have watched never mentioned downloading anything besides the Defold Engine, but this error makes it seem like I do, and I was just wondering what it meant and what I can do to fix it so I can continue working on my assignment.

Hi @noraw001 !

For which platform are you building?
Are you using “Build and Run” or are you bundling for a platform?

Is the unpack folder (e.g. C:\Users\orawe\AppData\Local\Temp\defold-unpack-*****\x86_64-win32bin/) empty?
Does the “luajit-32.exe” exist in that folder?

If it doesn’t, then I suggest checking your antivirus tools to see if it blocked the unpacking of the file. Which antivirus are you using?

I am building for a mobile platform and if I had to choose a more specific platform I’d choose Android. I also have only been clicking Project > Build. I haven’t tried the bundling so I will have to look into that.

Apparently upon a further dive into the folder the “/x86_64-win32/bin” doesn’t even exist. The only folder within “/x86_64-win32” is “lib” and I’m not sure why the “/bin” doesn’t exist?

I will have to reply again later when I have the time to check my antivirus information, but thank you for helping me for now.

1 Like

Thanks! This was the case for me trying to run the first ever test build. The anti virus scanner had it in quarantaine . Can’t get it working just yet since it still flags it as a virus but im getting there one step at a time…

Got it working by adding the luajit-64 file to the trusted files in the antivrus program.
Building now works!