Orthographic Rendercam displays objects too small or not at all (SOLVED)

#1

I’m trying out a 3D project to help me learn shaders, one of the things I want to add is the ability to switch between orthographic and perspective views in a similar way to Super Paper Mario.

The perspective view works fine, using the default values in the 3D project template:


However, if I switch to orthographic (without changing any settings), I get this:


It’s essentially the same view but zoomed out. If I try to turn off the perspective settings and use the default orthographic settings, I don’t see anything at all.

I’m not very familiar with the concept of perspective vs orthographic, which could be the issue here.

The expected result is to view the game from the side in 2D. Later on I want to be able to animate seamlessly between 2D and 3D modes.

0 Likes

#2

@ross.grams would know. There is an example project with RenderCam which I believe lets you switch between perspective and orthographic cameras, you should check it to see what it might have different that you need to set.

1 Like

#3

I had a look at the Rendercam example, it turns out the model is scaled up. Unless I’m missing something this seems to be ideal, the only other ways I can think of that makes the objects bigger are from zooming in really far with rendercam.zoom or by making the view area much smaller.

I’m also able to switch between camera modes easily now. I have two cameras, the orthographic one has a Near Z of -225, and the perspective one has the default settings from the 3D template, but the game object housing it is at a Z position of 500. The models are also scaled up, just like in the Rendercam example. Here are the results.

Orthographic:

Perspective:

I can work with this, thanks for pointing out the Rendercam example. :slight_smile:

3 Likes