Orthographic Follow Player

#1

Hi. I’m having trouble making the orthographic camera (from the asset portal) follow my player. Here are screenshots of my collection hierarchy and camera script arguments:

1

3

I’m able to move my player using WASD, but the camera does not move along with it. Nor does the camera center itself on the player either. The zoom works, so I know the camera exists and is enabled.

0 Likes

#2

In the follow target section of your camera, put the id of your player,.

0 Likes

#3

Exactly. You need to provide the id of the object to follow.

0 Likes

#4

da

Still isn’t doing anything. Tried it without the ‘/’ as well. Also tried ticking the “follow immediately” box. That’s the correct url, right? “Player” id is a root node of the collection.

0 Likes

#5

Did you try ticking the Follow box?

1 Like

#6

That helped, but why is there a Follow box along with two other Follow Vertical / Horizontal boxes? Also, what’s up with this camera? It’s moving faster than my character moves. If I walk just a few tiles, the camera is already far away from my character.

0 Likes

#7

Follow Vertical and Follow Horizontal are settings, in case you only want the camera to follow in one axis. As for the camera moving faster, try resetting all the options to default except for Follow Target and Follow.

1 Like

#8

Thanks for your help, but I was getting other weird issues to, like licking the “follow horizontally” button would change the camera’s movement to just shoot wildly out of control. I switched to the “Rendercam” asset instead and it’s working beautifully. Not sure what the problems were.

2 Likes

#9

Licking the buttons isn’t supported by

Licking the buttons isn’t supported by the editor. Even on a touchscreen, you’re going to get unexpected behaviour

6 Likes

#10

Oh, that makes sense. I will put in a feature request. Thanks!

4 Likes