#MadeWithDefold Jam 2023

I’m going to sit this one out - I have too much stuff going on right now - but I’m looking forward to playing what you come up with!

1 Like

It works but it is really slow (~25 minutes).For each iteration it creates an object and does a bunch of list operations. I’m sure it can be optimized significantly. But as @JCash said, we’d prefer if we could deprecate the Collada importer altogether (in favor of glTF).

Related ticket: https://github.com/defold/defold/issues/4434

The quick fix if we decide to keep the importer around is to not optimize meshes and let the developer do it outside of the Defold build pipeline.

Personally, I’d try opening it in Blender and then exprt it as .glb.

1 Like

Now that is one handsome zombie and huuuuge, way too large to use for a game. :grinning:

You don’t need to replace it if you don’t want to - as @Mathias_Westerdahl said, Blender can export to this format - I have just tried this and the file has shrunk to about a quarter just by doing so.
Screenshot 2023-05-10 at 13.57.32

Also, you can decimate this mesh by a very large amount with help of the decimate modifier - I quickly did reduce it to 10 % and it still looks good - but you will need to clean up a bit afterwards.
Screenshot 2023-05-10 at 13.58.41


Thank you guys! How do you know how many polygons a model have? I was looking for “low poly” models, but I don’t think 420k is low poly, right? :smiley:

EDIT: Exported it to glb (after Decimating to ~25%) → not only it loads faster, but I also managed to get textures xD Thank you @anon95708182 !


Nope, this is certainly not a low-poly human figure. :grinning: I’d say, a couple of thousand vertices would be, hm, maybe 3000 or so if it should look detailed enough? :thinking:
If your source doesn’t tell you the amount of vertices etc, Blender does on the bottom right side:
Screenshot 2023-05-10 at 15.12.29.

1 Like

@pawel I got the same issue with missing files:

ERROR example/objects/backroom.go:0 the component '/assets/trees/backroom.model' can't be found
ERROR example/objects/deadtree1.go:0 the component '/assets/trees/deadtree1.model' can't be found
1 Like

We have a PR awaiting review now for that extreme loading time for large collada models.


There could be a warning or so that model has extreme values of polygons? (though I’m not professional and I should have checked it before :sweat_smile: )

Well, that’s very subjective, and we wouldn’t know what you think is ok for your project and target hardware.


Ok, now it bundles in few seconds! Thank you so much guys, new commits coming! :slight_smile:


Day3 : Collision took a bit more focus than I had thought. Tried to grid the playfield into a tilesource and use the auto generated collision shapes , turned out that larger the tile the less accurate and the smaller tiles still didn’t give me satisfactory results ( bumpy lumpy lines).


So I went with convex hull which turned out to be 78 .convexshape files and works well. However I will have to come back to this after the jam as it could be optimized as there are tri’s that will not receive collision and I should come up with a better way to generate the vertices in a more accurate way.

It works well and thats what counts so now I can move on to trying to nail the dynamic physics for a fast heavy feeling responsive pinball , fingers crossed.


I have weird behavior I never noticed before, but I must have done something in my project that is causing it - currently I can’t run (build from Editor) my project, because the Editor closes abruptly without any error/crash. There is a .log file in Defold’s binary location, maybe something from here should point out the problem?

hs_err_pid11667.zip (35.3 KB)

I’m assuming you’re not using the beta?
By looking at the log, it’s the model loader that asserts.

In the beta we have more robust handling when the model fails to load.
Could you try the beta?

1 Like

I added few new models, so maybe. I’m trying to revert one by one, but didn’t yet found it. I’ll try the beta :wink:

EDIT: It works in beta 1.4.6 @Mathias_Westerdahl :wink:


Day 4: Improved respawning system and reduced polys (this time actually, because previously I… I didn’t apply Decimate modifier in Blender… :sweat_smile:). I also cut out highest branches of the models, because there were too many branches already and players will rarely look up anyway, not worth the polygons, it has to be running on my poor machine :grinning_face_with_smiling_eyes:


I would really love to spend some time on trying to add the shadows, it would surely make this waay better, but I can’t comprehend it as of now yet :slightly_frowning_face:

1 Like

Make my own map in trenchbroom. It was hard at start but when i understand how it worked and remember hotkey it is very cool.
Infinity is ready:)
When i move previous floors are removed and new floors added.


I really feel like stretching the engine, but I guess it’s out of my lack of knowledge :sweat_smile:

I have a crash that appears after some time of gameplay (Linux, 1.4.6 beta):

_crash.zip (1.0 KB)

Day 5 and paper sheets to collect are there (+ further optimizations!)

Callstack from the attached crash:

/home/pjarosz4/Desktop/witchcrafter/build/x86_64-linux/dmengine() [0x67fdf5]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x14420) [0x7f933d906420]
/lib/x86_64-linux-gnu/libc.so.6(gsignal+0xcb) [0x7f933d3ef00b]
/lib/x86_64-linux-gnu/libc.so.6(abort+0x12b) [0x7f933d3ce859]
/lib/x86_64-linux-gnu/libc.so.6(+0x22729) [0x7f933d3ce729]
/lib/x86_64-linux-gnu/libc.so.6(+0x33fd6) [0x7f933d3dffd6]
/home/pjarosz4/Desktop/witchcrafter/build/x86_64-linux/dmengine() [0x67038b]
/home/pjarosz4/Desktop/witchcrafter/build/x86_64-linux/dmengine() [0x45ad90]
/home/pjarosz4/Desktop/witchcrafter/build/x86_64-linux/dmengine() [0x669558]
/home/pjarosz4/Desktop/witchcrafter/build/x86_64-linux/dmengine() [0x458c93]
/home/pjarosz4/Desktop/witchcrafter/build/x86_64-linux/dmengine() [0x42ea6f]
/home/pjarosz4/Desktop/witchcrafter/build/x86_64-linux/dmengine() [0x452e16]
/home/pjarosz4/Desktop/witchcrafter/build/x86_64-linux/dmengine() [0x42ea6f]
/home/pjarosz4/Desktop/witchcrafter/build/x86_64-linux/dmengine() [0x414891]
/home/pjarosz4/Desktop/witchcrafter/build/x86_64-linux/dmengine() [0x414ec5]
/home/pjarosz4/Desktop/witchcrafter/build/x86_64-linux/dmengine() [0x41148f]
/home/pjarosz4/Desktop/witchcrafter/build/x86_64-linux/dmengine() [0x4113f5]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf3) [0x7f933d3d0083]
/home/pjarosz4/Desktop/witchcrafter/build/x86_64-linux/dmengine() [0x41123e]

It looks like this is a crash from a release build. Can you either share debug symbols or share a crash from a debug build?