Low performance in html5 bundle (SOLVED)

#1

Hi! I do not know what it is, but it’s more like a bug.
There was a problem with the performance of the game in html5. When I press “build html5” then the game plays fine, but when I press “Bundle>HTML5 Application” and run on my server, I get terrible performance!
ctrl+b

build html5

BundleHTML5 Application (WITH LOW PERFOMANCE)

How do you think, how can you solve this problem? html5 is very important for me :frowning:

Thanks!

0 Likes

#2

try checking and unchecking the “release mode” when bundling. I believe that can cause issues. You should also check if browsers that are not chrome have the same problem (check in firefox). you should also try clearing your cache.

Another with a similar problem was able to get rid of performance problems this way.

1 Like

#3

Thanks for answer!
Switching mode does not affect.
But, you’re right! In the Edge, Safari and Firefox game works perfectly!
In chrome and opera, the game is very slow.
I reinstalled problematic browsers, cleaned the cache - but the problem remains.
If I test in chrome directly - the game works well, if through the assembly of the bundle - the game freezes.

What do you think, where else can I look to solve this problem?
Thanks!

0 Likes

#4

Are you using a native extension? Native extensions currently always generate debug builds. Debug builds does a lot of calls to check for webgl errors and this is slow on Chrome. If this is the case you have two options:

  1. Bundle with an app.manifest file that replaces the debug version of the engine with a release version. Check here for tools to generate app.manifest files: Stripping appmanifest maker
  2. Edit your index.html file and explicitly disable graphics call verification.

Like this:

var extra_params = {
    archive_location_filter: function( path ) {
        return ("{{DEFOLD_ARCHIVE_LOCATION_PREFIX}}" + path + "{{DEFOLD_ARCHIVE_LOCATION_SUFFIX}}");
    },
    engine_arguments: ["--verify-graphics-calls=false"],
    splash_image: "{{DEFOLD_SPLASH_IMAGE}}",
    custom_heap_size: {{DEFOLD_HEAP_SIZE}}
}
8 Likes

Windows 10(HTML5): Edge/Firefox OK, Chrome/Opera SLOW?
Defold 1.2.141 has been released
Rabid Robots (web) - (Released)
#5

Yes you are right. Timer is used)
Two of these ways helped.
Thank you!

3 Likes