Java PrivelegedActionException : Unknown (SOLVED)


#1

Hey,
Just got a new error wwhen building again for android, or any platform in that case.
After this error it shows error in opening zip file.
Looks like all errors have a fatal attraction towards me :cry:


#2

Does this happen when you bundle an empty project for Android? Does this happen when you bundle for desktop or HTML5? Can you paste the entire error from the console?


#3

Do you have any more information on the error? Can you take a screenshot?

Reminds me of a similar error I recently looked into, but not 100% the same?

java.security.PrivilegedActionException: Unknown
java.util.zip.ZipException: error in opening zip file

#4

Yes

I tried building an empty project today but it bundled perfectly.
And here is the sceenshot :

200% the same. :stuck_out_tongue:


#5

What folder do you bundle to on your computer?


#6

Can you please Report?


#7

If that is the case, the previous issue was due to a library zip being corrupt. I solved it by opening and deleting the contents of the <project_folder>/.internal/cache directory… Could you try that? (I would recommend you backing up your project before doing this if anything goes wrong. :wink: )


#8

I tried deleting the cache and finally the error has stopped popping up.
Just one more thing, what is the expected build time for a 400mb project. It has just been at building engine for 2 hours now, and counting?


#9

400Mb!!! What does the 400Mb consist of?


#10

NVM I was able to build it :sunglasses:. Thanks @sven for your idea