Java error when testing game (SOLVED)

#1

Today is my unlucky day. There I was, minding my own business, when:

java.lang.AssertionError: Assert failed: Cycle detected on node type editor.code.script/ScriptNode and output :build-targets
(not (contains? (:in-production evaluation-context) [node-id label]))

46

This happens every time I try to test the project. Any idea of how to… continue using Defold now? :slight_smile:

1 Like

#2

Found the issue: Two of my modules try to require each other. Aside from spaghetti warning, I suppose this is not allowed?

0 Likes

#3

No, that creates and infinite loop of require().

2 Likes

#4

Just had this error as well and this solution worked for me (didn’t realise looping require() was bad but of course makes sense now that I think about it). There were a couple of other threads with the same error message, but seemingly different root causes (something to do with GUI or factories, for example). Is there a way to make the error message more informative? Or maybe it already is, but I just don’t understand it?

0 Likes