Issue with Defold [Linux/Manjaro] (SOLVED)

#1

Hello!

I wanted to give Defold a go as I’m studying Lua to do some game dev (not so quiet confident with frameworks so engine sounds best at this point.) I’m running Defold on my Manjaro linux laptop and I’m having issue opening any .collection or editor itself with this error showing up - https://i.imgur.com/dh9LIPR.png

java.lang.ClassCastException: class jogamp.opengl.es1.GLES1Impl cannot be cast to class com.jogamp.opengl.GL2ES2 (jogamp.opengl.es1.GLES1Impl and com.jogamp.opengl.GL2ES2 are in unnamed module of loader 'app')

I apologise if written in wrong category, I couldn’t find any fix on this and I wasn’t sure where to post this.
Thank you!

0 Likes

#2

Yes, it’s not always easy to get things working on Linux (our supported version Is Ubuntu 18 currently).
We have a small F.A.Q for the most common issues, and I’m thinking the part with the MESA version might help:

$ export MESA_GL_VERSION_OVERRIDE=3.1
$ ./Defold

Perhaps that might help?

1 Like

#3

I had the same issue on AMD Radeon card on Linux Mint, it happened after I tried to install OIBAF drivers.
See if you can update/fix graphics drivers safely somehow. In my case I had to reinstall OS :confused:

Good luck and godspeed!

1 Like

#4

Thank you for your reply (and @Dzuvan)
Sadly neither of them worked, which is a shame because I was hoping to have it work on my Linux device. But with it I think it’s time to go back to Win due to few issues my laptop is having enough as it is with Linux (oddly enough, never had those issues but that’s off topic)

1 Like

#5

I have to bump this :confused:

Recently I started getting this error again. Everything was working and one day it stopped.
Issue is happening on Linux Mint 20 and PopOS both of which are clean installs.

Mesa driver export didn’t help.

0 Likes

#6

When did it stop working? We recently updated Cljfx https://github.com/defold/defold/pull/4926

@vlaaad, could this be related?

0 Likes

#7

I think somewhere between 4 and 7 days ago.

0 Likes

#8

I don’t think it’s cljfx-related, it looks like a driver issue. Cljfx doesn’t really do anything with drivers. Have you updated drivers @Dzuvan?

0 Likes

#9

Nope, I only reinstalled os.

0 Likes

#10

Could it be that the reinstallation triggered a driver update as part of the installation process?

0 Likes

#11

Don’t think so, I installed 2 diferent distros, and same issue.

0 Likes

#12

Hey,
I have the same issure on ubuntu 20, and sometimes this message appears too;
java.lang.ClassCastException: Unknown. I can build project, but I can’t see scene before.
My OpenGL version is 4.1 and Mesa version is 20.0.4, if it’s important. (export mesa didn’t work)
Also I tried working on Defold in Vbox (virtual machine) on Windows 7, Def. behave itself very strangely
I can see scene, but turned upside down specularly, and it reacting to cursor like if cursor is in the bottom while it is in the top and vice versa, and I can’t build runtime, there is error in console:ERROR.GRAPHICS: dmgraphics:: OpenGLSetTexture(2363) Assertion failed: 0, file ..\scr\opengl\graphics_opengl.cpp. line 2363
Thank you.

0 Likes

#13

Hi @xxxKfkxxx!
Did you get any other output when the dmengine crashed?

As for the Ubuntu 20 + OpenGL support, can you provide your editor log?

0 Likes

#14

In the end of first line there was some unreadable symbols like it was emoji (Defold in vbox)

Defold’s log for Linux or Defold’s log for virtual windows ?

P.S. Thank you for such fast answer.

0 Likes

#15

For the dmengine error, I would have expected a line containing “gl error”. It should have printed the error number and the human readable repesentation of the error.

As for the log, I meant the Defold Editor log, for for being too vague :slight_smile:

0 Likes

#16

I decided to attach both logs
Here is Linux’s log
Linux.txt (907.6 KB)
Here is virtual Windows’s log
Windows.txt (219.9 KB)
i hope there is what did you want

0 Likes

#17

Indeed your editor log from Linux, has the same issue of not selecting the proper version of OpenGL.
Did you try this?

export MESA_GL_VERSION_OVERRIDE=3.1
$ ./Defold
0 Likes

#18

Yes, I tried again 1 minute ago. Nothing changed.

I resently started using Linux and I don’t know if it should write smth back if this command was done correctly.

Also I have nVidia GeForce MX250 videocard inside my laptop. Maybe that couse issue?

0 Likes

#19

For some reason, it seems it picks an OpenGL 1 context when starting Defold. I’d start looking there. Do you have any issues with other apps?

0 Likes

#20

Hello together…I just wanted to report…i have the exact same issue with Ubuntu 20.04.

export MESA_GL_VERSION_OVERRIDE=3.1 diden’t help.

However, i have two Computers…both with Ubuntu 20.04. One has the propritary Nvidia-Driver with a GTX1650…there Defold works without problems…an the other one is a Notebook with Intel integrated graphics (i5-6200 CPU)…there I have the same Problem as xxxKfkxxx.

1 Like