Is the editor almost unusably slow for any other Linux users?

#1

I’m using editor v1.2.175 on Ubuntu 20.04 and it’s painfully slow almost to the point of being unusable especially when editing tilemaps/sources. I’m running off of a Samsung 860 EVO SSD with an Intel Xeon E5620 and AMD Radeon RX 570.

0 Likes

#2

It’s running fine on my side(Ubuntu 20.04 LTS). The only problem is that the menu’s font-size are small. But I can easily change that.!

2 Likes

#3

Hmm, what editor version are you on? Is your computer significantly more powerful than mine?

0 Likes

#4

I have noticed that attempting to open a large tilemap, tilesource, atlas, or any other graphical asset in the editor causes it to stall. “Large” varies. For example, I once tried using a 8192 x 8192 atlas. Every time I would open the atlas in the editor, I would be stuck at a non-responsive blank screen for a solid 10 to 20 seconds. Perhaps your assets are comparatively large? I am also running Defold on Windows, so I cannot speak for Linux specifically.

1 Like

#5

Maybe try downloading OpenJDK and replacing the implementation in packages for Defold. I noticed a speed improvement in Windows doing this, but also had some non-serious error popups occurring more frequently so I reverted. Still, if it helps it be more usable it might be worth it.

0 Likes

#6

I’m not using particularly large assets, I’m just using the “RPG Urban Pack” from Kenney. I tried using my system installation of OpenJDK 11 and it refused to even start. The interface is similarly slow on other computers I tested although I was unable to test the tilemap editor as it doesn’t seem to work on Intel integrated graphics.

0 Likes

#7

This is not recommended. We cannot provide support if you change the JDK.

1 Like