iOS bundle: signed with invalid entitlements

#1

Don’t know why I keep getting this error when I tried to bundle to my testing iOS device:
18

This error only appears recently (it was working just fine before). Is this because I update my phone to 13.3.1?

Reinstall Xcode 10.3 didn’t solve the problem.

The tutorial I followed is this one: https://defold.com/manuals/ios/#developing-using-a-free-apple-developer-account

0 Likes

#2

Did you remake your provisioning profile and it still doesn’t work?

0 Likes

#3

Yes, many times!

0 Likes

#4

Does a project built directly from xcode run on your iPhone? Try opening iTunes and see if you need to enable the device for development.

0 Likes

#5

Does a project built directly from xcode run on your iPhone?

Yes, it does.

Try opening iTunes and see if you need to enable the device for development.

I’m not sure how to do this but I did enable the app in Settings -> General -> Device Management

0 Likes