How do you initialize git version control in the editor? (SOLVED)

When I go to File > Synchronize... it just says “This project does not use Version Control” and provides a link to the Version Control docs, but I don’t see any instruction on initializing Version Control.

I tried manually creating a git repo by running git init in the projects root directory, but File > Synchronize... still says “This project does not use Version Control”.

I know I can just use git outside of the editor, but I like the built-in Version Control features, as simple as they may be.

You need to close Defold and reopen it so that it detects the new repository. But yeah, to my knowledge there’s no way to initialise a repository from within the editor.

Correct, there is no way to init a new git repo from within the editor.

And yes, it seems like a restart is required. But that should be something we could fix ofcourse.

1 Like

So I tried restarting the editor before, but I think the issue was that I hadn’t ran git add --all so the repo was still empty. It’s is working now.

1 Like