Help! plz, Android can't bundle! (SOLVED)

#1

Hi,Dear developer.
My English was bad bad, If you can’t read I 'm sorry. But please help me.

I 'm chinese use, I use VPN work.
I bundle android apk this morning(10:00~12:00), and it was success,
but when opening project can’t download monarch on github, so
the game can’t change scene alway still on “openscene”,even debug mode.

After 14:00 , Project download monarch success, but bundle android apk was fail.
I try again on Mac, fail too. it was same error :
java.security.PrivilegedActionException: Unknown
java.util.zip.ZipException: zip END header not found
Please Help, under was mac screenshot and mac log, window log



defold erro.zip (220.5 KB)

1 Like

#2

It seems like there’s a corrupt dependency (zip file) in your project. Remove .internal/lib/*.zip and then do Project->Fetch Libraries again.

3 Likes

Bundle Android Application not working (SOLVED)
How do I fix these errors?
#3

Thank you, just network problem, it can build now. I use offline library, project open speed fast than before.

0 Likes

#4

And I hope can build gradle project in future, so I can work on android studio.

0 Likes