GUI Stencil clipping overlays other GUI (SOLVED)


#1

Here’s a picture of how I have it set up.

I have the clipping on both of the highlighted GUI boxes, Screen_Frame and Frame, set to stencil. When Screen_Frame’s clipping is set to stencil, it doesn’t allow GUI nodes created inside Frame to be visible.

How can I get around this?


#2

Is it an option for you to have both Screen_Frame and Frame inside the same gui scene? I’m quite certain that would fix the issue. The issue is caused by the clipping system, which assigns different nodes to the different bits of the stencil buffer. However it doesn’t always work correctly across multiple scenes, as nodes from the second scene can get the same bits assigned, which then conflicts with the first scene.


#3

Thanks for the reply, and yes, quite possible! I actually made that change this weekend, realizing it was more complicated the way it was. I didn’t think to test the clipping mode again, though. I’ve just set it to none for testing. Let’s see if I remember to test it and reply! :smile:

EDIT: When I originally read gui scene, I was thinking the object in which the gui scenes were. In the end, I just moved them into the same object and not the same scene. Setting the scene at the top of the screen’s clipping setting to none works for what I need.