Font error when bundling (SOLVED)

When running my game in the editor, I see this on the title screen for example:

Screenshot 2023-01-29 043209

But when building for Windows Release, I see this:

Screenshot 2023-01-29 043236

The . character disappears. When the player types their email into the leaderboards area for registering a PlayFab account, the same issue occurs.

I’m using the mongram font, found here: monogram by datagoblin

I tried checking “All Characters” in the editor, however that did not seem to help.

Could you please create a ticket on GitHub?

I wrote out the full issue report with an example project, but playing with it some more I discovered it is the monogram font itself at 16 px size causes the . character to disappear. I tried different sizes and it does work, so I will be swapping fonts for my game. Anti-aliasing did not affect the result.

Edit: After switching to m5x7 font, the same is happening at 16 px. I’ll make a ticket.

Bug report is here with minimal project attached:

1 Like

Are you using a bitmap or distance field font?

Both tested fonts are bitmap.

I’m able to repro it here. We’ll look into it, can’t say exactly when though.

1 Like

Solved this problem by editing the TTF file a bit. The problem in Defold engine is not yet fixed, but the workaround works without negative artifacts. See GitHub ticket for details. I’ll mark this forum post as solved.

1 Like