"Fetch was aborted because a host could not be reached"

#1

I recently wiped my computer and have been setting things up again. I’ve cloned my projects off GitHub. When I attempt to open them, I get a message like this:

image

If I try to fetch the dependencies, I get the following:

image

I assume it’s something wrong on my end because:

  • GitHub seems to be fine, and I can access each of the zips manually;
  • The projects work on my other machine; and
  • I have created an empty project and added only one of the dependencies, leading to the same result.

Here are the logs - they don’t look useful to me but I don’t know what to look for :slight_smile:
editor2.2020-06-22.txt (24.0 KB)

I imagine it’s something silly - a firewall setting or something? - I just don’t know what to do about it. I’m on Windows 10.

0 Likes

#2

I’m having issues with GitHub too.

image

1 Like

#3

Was hoping the issue would magically disappear overnight, but it seems to persist today. If anyone has any ideas feel free to chime in!

Is everyone else able to fetch libraries as normal?

0 Likes

#4

Fetch libraries works for me. You say you can fetch them manually, you mean with a browser/curl/wget? I would also guess a firewall issue, is java.exe from somewhere in your defold directory in the list of allowed apps in windows firewall? (control panel, system and security, windows defender firewall, allow an app through windows firewall)

1 Like

#5

Yes, I meant just copying it into the browser to check the zip itself was reachable.

You’ve solved the problem for me (though not sure if @benjames171 is having the same issue). I tried to allow java.exe (Defold\packages\jdk11.0.1\bin) through the firewall but got a message saying something like “OpenJDK Platform binary is already in the list”. I did notice that the “Public” tickbox was empty, so I ticked it and problem solved!

image

3 Likes

#7

I’m having the same github issue here, except I’ve completely disabled my firewall and it still won’t connect. Oddly enough my laptop can fetch from github but not my PC. Same unreachable host error message.

0 Likes

#8

Try flushing DNS cache on your PC?

0 Likes

#9

Flushing the DNS cache didn’t work; it’s really odd…

0 Likes