Editor crashes on startup with hs_err_pid.log

#1

Hello,

Recently the Defold editor started crashing for me right after the splash screen, and a java crash log appears:

hs_err_pid13736.txt (58.8 KB)

I’m not sure exactly when this started happening since I didn’t use the editor for a couple of months, so probably due to some java update in between?

I have the latest editor version 1.2.173 and I tried updating both my JRE and JDK to the latest.

Any ideas? :smiley:

1 Like

#2

And it works if you revert to 1.2.172?

You should not need these for the editor as we bundle a stripped down version of OpenJDK 11.0.1 for use by the editor.

0 Likes

#3

These lines from the callstack suggest that something goes wrong when getting an OpenGLES function:

j jogamp.opengl.egl.EGLContext.dispatch_eglGetProcAddress0(Ljava/lang/String;J)J+0
j jogamp.opengl.egl.EGLContext.eglGetProcAddress(JLjava/lang/String;)J+18
j jogamp.opengl.egl.EGLDynamicLibraryBundleInfo.toolGetProcAddress(JLjava/lang/String;)J+2

It doesn’t seem to print the name of the function it is trying to get though.
Since it’s graphics related, perhaps there’s something to do with your graphics driver?

0 Likes

#4

Nope, just tried it. Also I updated to 1.2.173 after I started having this problem hoping that there would be a fix, so I got it on an earlier version, can’t remember which exactly…

This I am 99% sure I did not update since the editor was last working. After getting the problem I tried updating that as well, now on GeForce 456.38. But I’m still getting the crash…

1 Like

#5

Sorry for the bump, but is there anything else I could check? :slight_smile:

0 Likes

#6

This JOGL issue, although on Linux Mint, mentions duplicate drivers installed, one for OpenGL and one for OpenCL. I saw that you have Nvidia GPU Computing Toolkit (CUDA) on your path. Is that something which you have installed recently?

0 Likes

#7

Thanks for the response :slight_smile:

I did have CUDA installed, but for a long time during which I was using Defold normally. I uninstalled it just in case and nope, same issue.

0 Likes

#8

Could these lines from the crash log mean that it’s somehow running out of memory?

Usage:
  Non-class:     28.77 MB capacity,    28.25 MB ( 98%) used,   443.76 KB (  2%) free+waste,    93.19 KB ( <1%) overhead. 
      Class:      3.97 MB capacity,     3.63 MB ( 92%) used,   298.61 KB (  7%) free+waste,    45.31 KB (  1%) overhead. 
       Both:     32.74 MB capacity,    31.88 MB ( 97%) used,   742.37 KB (  2%) free+waste,   138.50 KB ( <1%) overhead. 

Virtual space:
  Non-class space:       30.00 MB reserved,      29.00 MB ( 97%) committed 
      Class space:        1.00 GB reserved,       4.00 MB ( <1%) committed 
             Both:        1.03 GB reserved,      33.00 MB (  3%) committed 

How could I add commandline args to java in order to try more things?

0 Likes

#9

In your editor folder, you’ll find a “config” file, which has the startup settings for the app.

0 Likes