Editor 2 - dmengine versions

How do I get the latest dmengine versions using Editor 2.

My setup is that I run a server/client game and when I compile/run from editor I run my server.
Then I use terminal to run a second instance that is the client (using the latest stable dmengine)
The latest update of Editor 2 that came a few minutes ago totally ruined the transformations of my models and one guess is that it is due to something changed in the dmengine (not sure though) but building the project in Editor 1 and running in the same way is still working fine.
So I wonder, when you push these small updates for Editor 2, is there a easy way to get the latest beta dmengine as well? Guess it is located within the Defold package but I wondered if there was an d.defold.com link for that version?

I will start error checking there at least.

There is a related post here which explains how to download the latest bob/engine.
The same info.json exists for beta builds

Replace that sha1 with the one of the beta editor that you use:


Thanks Mathias. Will look into that

1 Like

Just trying to use dmengine on device. Downloaded it from http://d.defold.com/archive/a79a2120e3ba781eedeb83e2dee6f1391a084216/engine/armv7-android/dmengine.apk with correct sha string (the same in editors about window). Set targer in editor2 and got: [Running on target 'bq-Aquaris X5 Plus' (] INFO:ENGINE: Defold Engine 1.2.108 (a79a212) FATAL:ENGINE: Unable to load project file: ''
With crashing dmengine app on device.
what i’m doing wrong?

ps. device in dev mode, I work on windows 10

Hi @Dragosha!
I don’t think you did anything wrong, the engine shouldn’t crash.
Does it crash immediately when starting the app, or when you connect to it, or when you “build and launch” towards your target?
Does the adb logcat output reveal anything useful?
What OS version do you run on your phone?

1 Like

It crash after I push “build” in editor2. Then editor write in console fatal:error (see above) and app crash at device.

hmm, I didn’t install android studio with this tool at PC . Will install and show.

android 7.1.1

Hmm, not sure what could cause this. Perhaps @Ragnar_Dahlen or @Erik_Angelin knows more?

UPD: tried to “build and launch” in editor v 1. with dmengine 107 on the same device and it’s work fine.
so, it issue with editor v2 and dmengine v108 only.

1 Like

We have just verified this issue on Windows, and we’re looking into it.

It’s good that you have a workaround with using Editor 1 for a short while!


Just want to inform that the bug is now on editor 1 as you updated it.

Hmm, do you mean the “Unable to load project file”?
We fixed that issue in Editor 2 yesterday, and that was an Editor 2 issue when targeting an Android device from a Windows machine.

I could not reproduce that issue on Editor 1, so I’m very interested in any info/logs you have!

No the transformation/animation of models that became screwed up.
I added Ragnar Dahlen to a testproject which showed it and also had Ragnar Svensson and Erik Angelin invited in a message thread about it. Also showcased it some days ago when I was at the office.
I could invite you as well to the project and try to show it with a better animation as well.

Ah, gotcha. Yes, please invite me, and I’ll talk to @Ragnar_Svensson about it (the others are on vacation now)

Invited. But hold your horses a little bit. It seems like the maya versions we couldnt use before now seem to work a little better but the blender solution we had is the one failing now.
I will go back and see if we made some manual fixes that now need to be restored.

Still scaling of bones is not working at all unless <unit meter= … is manually set to “1.0”

1 Like

Looking at the animations right now I just can’t say if the bugs that are occurring is something that is still a known issue in the engine, if it is an unknown one or if it is one that you think has been fixed. Therefor it’s hard to know how to proceed (filing an issue or just waiting it out?)
All I know is:
All this time, unit scale for bones has never worked at all unless you set it manually to 1.0 in the dae file. This will make the animations look ok.
Even if doing so it seems like bones are not transformed due to this scale eg. will give bad position when using go.get_position on such bone. (still is in it 's non scaled position).
Before, Maya exports did not work properly and you had to import/export that file through blender.
Now Maya exports work but the files gone through blender does not.

The unit-scale issue has previously been filed as DEF-2710. If you give me access to your project with some instructions how to reproduce, I can take a look monday. If you want to increase the likelihood of me being able to fix it, you can make a new project with only the assets that causes the problem (i.e. the model, animations, a script to provoke, etc.). It would save me a lot of time.

1 Like

I have a demo project showcasing it all. I will invite you and send instructions on how to replicate it all via messages.
Thanks in advance!



DEF-2710 has been fixed in Defold 1.2.110