Dragon Bones 4.9.5 supports spine 3.3


#21

@Davej 4.9.5 is the one that fails to login.
We can safely proclaim spine export in DB broken at this point


#22

No it’s not I use it all the time whats wrong?


#23

@Davej you must have registered an account at the chinese egret website and do remember your password - unlike me.
I tried entering it multiple times, tried getting it sent to my email, tried registering again - nothing works. Its frustrating


#24

aaaagh, ok setup a different account, I do remember having trouble registering, but once your password is in, your never asked for it again.


#25

I am not alone in my frustration either.
Mike from Gamesfromscratch (who makes excellent tutorials for Defold btw) made a video on Dragon Bones and he gave it a fairly negative review:

https://www.youtube.com/watch?v=ZjKBxgZ6zvE

Due to the weird chinese website login requirement!

It’s very rare for him to be negative in a review, but in this case it is justified imo. He had to downgrade to 4.7 in order to use dragonbones at all. This kind of isolates dragonbones from the international user. I don’t know if any of it’s developers are aware of this problem - but it seems to be very dificult to contact them.

I will give it a try on twitter

@Davej I can’t setup a new account, because the developers have closed registration until the chinese new year passes - presumably according to google translate. But on a different occasion the website did not load at all


#26

o that sucks, hope it’s only 1 day like ours, and they don’t celebrate longer.


#27

@Davej - unfortunately this kind of stuff is a deal breaker :confounded:

I will not be able to register for another month or so, according to information on the internet:

The festival lasts for about 23 days, ending on the 15th day of the first lunar month in the following year in the Chinese calendar.

So Egret basically disabled anyone new from trying to export to spine for an entire month, while they continue to roll out updates for it.

Weird


#28

I have 4.9.5, never created an account, and can export spine fine… maybe one of the public installers of 4.9.5 was updated to add login requirement?


#29

@Pkeod that is possible.
A fair warning to everyone who wants to use dragonbones to export spine is to not update when the application promps them to do so.

I can test it on my side if you zip your copy of Dragonbones and upload it somewhere.

:slight_smile:


#30

I’ve completly deleted everything related to DragonBones and it’s still asking for the login on v4.9.5. Maybe one of you could upload the version you have so we can try it instead please.


#31

It would be good if we figure out some sort of a workaround! Or even use an open source alternative to dragonbones entirely.

Btw I succeeded to create an account and export at home (chinese new year festival must have ended- their registration is back online), but when i try to export from work, i get a network error and refuses to export.

Even if you have an egret account, the spine export is not going to work on some networks. This is a terrible design.
With andy’s dragonbones export in coa_tools, we will not be able to export from blender to Defold directly and will still have that network error block.


#32

I believe the way forward is when the plugins become available for editor 1 and 2, then we are free to create import plugins for coa-tools and dragonbones our selves, I personally like the look of coa-tools, as it’s all open source.


#33

md5 of the installer I still have is

9fffdc6e7127a2ff07a533db26c1244b

DragonBonesPro-v4.9.5.exe

Can you check the md5 of the copy you have?

http://www.winmd5.com/

Uploaded here https://archive.org/details/DragonBonesProV4.9.5


#34

Thank you @Pkeod
I will give this a try tomorrow.

Try disabling your internet connection prior to starting dragonbones.
Then after starting it, try exporting to spine

It is also possible that it writes some files to the user settings folder

here is a screenshot of the network error message I have on 4.9.5 - but the one from their official website

I will test the web archive one you provided soon


#35

Downloaded and tested, this version 4.9.5 does definitely not have the login requirements, thanks @Pkeod for this.


#36

It would definitely be great if we had an open source editor for skeleton animation that is not affected in any way by company politics and has no such network restrictions imposed.
It’s made by the community, for the community!

The closest to that is the Coa Tools plugin for blender. But here are a couple of issues with it atm:

  • it exports only to dragonbones json file type, so we still need the dragonbones pro editor with the restrictions in order to convert the animation to spine2d format that defold can read
  • Ndee seems to be the only developer actively supporting it and the plugin does need maintenance to make sure it works with the latest version of blender
  • We need to check the legality of writing an unofficial spine2d exporter - it seems to be ok for dragonbones chinese devs, but they might have a deal with esoteric that gives them permission. Is it ok for the community to create an exporter?

#37

I was thinking an importer for a quick solution, but ultimately a native extension to create the animation would be best, sort of a bespoke dragonbones extension, which legally wouldn’t be a problem as Defold has it’s own runtime.


#39

It still fails to completely export for me - even with the version @Pkeod provided!

It is deceiving in a way - because it gives you this message:

but once you ok it by clicking “confirm”, you get this message:

and finally if you look at the export folder- it exported the image files, but NOT the spine json file


#40

Did anyone do a MD5 of the other 4.9.5 installer they had?

Try to clear your appdata for dragon bones (backup first)?


#41

After having cleared the dragonbones folder, still getting the network error problem!

Can you try on your end some things:

  • disconnect your internet and try to export to spine, check in the target output folder if the json files have been generated
  • check in the preferences window if you are logged in

I can confirm that the version that I am running has the same md5 checksum:
9fffdc6e7127a2ff07a533db26c1244b