Do not open this suitcase: devlog


#62

Ok, I can reproduce the java null pointer exception too now. Thx!


#63

that’s great! I really tried my hardest to check absolutely everything to find the problem, but I’m sure it will something small that i missed. good luck…


#64

Well, I found the culprit.

It seems that for some reason, you have files named “._griddy2.png” etc, in your images folder.
These currently mess up for bob.jar, which is used to bundle projects, since they are not actual .png files. They seem to come from your systems Quarantine or Preview? I’m not familiar with those types of files.

The first workaround, is ofc to make sure there are no such “broken” .png files in your project.

We are also going to add a better error message when this happens. I’ve added DEF-3264 for this.


#65

They are related to the Mac Operating System, and they are hidden to normal users. I suppose the easiest thing would be to automatically exclude them from the build?

edit… okay, this is really weird. I have turned on “view hidden files” and although I can see some hidden files (the .gitignore, for example, among others) I can’t see any related to those PNGs. I tried deleting the whole folder and recreating it. But i still get the error.

(note the .internal, .gitignore, .git files viewable at the bottom, and the lack of viewable files related to the images)


#66

Well, the Editor 2 does just that (unless you reference them directly). However Editor 1 (and bob.jar) which is still used to bundle the packages, builds all resources before a bundle, which will encounter these files.


#67

Okay, that’s strange, because I have I tried building in the standard editor 2 build (previously i was using britzl’s special build) and now i get this error message:

22

Could you possibly do me a huge favour and delete all the troublesome files and then synchronise? I have no idea how else to proceed here.


#68

Sure, I’ve synchronized the project now!

Fyi, I used the command line (Terminal) to find them:

mathiaswesterdahl ~/work/projects/88.josh/main (master)  
$ find . -iname "._*.*"
./beep/._modemconnect.wav
./images/._griddy2.png
...

I’m not sure where to start actually, when learning bash, if there are any good tutorials or not (any of our users know?).
It’s a really good tool to know how to use. E.g finding files, renaming files, running multiple things one after another (e.g. build scripts), are all things that one will encounter when doing game development.
Although one would like the tools to be perfect, it’s usually the case that one wants to do something extra specific, that the tools won’t support. Then bash comes in handy.


#69

There are so many things I should learn! But, it’s the first time I’ve had this problem. hopefully it won’t happen again… i have many other problems i could improve on…

Thanks for your help @Mathias_Westerdahl!


#70

Released in Defold 1.2.127


#71

@britzl, i have still been using your old build with the edits you made to allow for Android key presses… have they been merged into the main build now?


#72

Oh yes, that was done a few releases ago.


#73

great britzl!

I’ve just been sent this image from the product designer working on the new version of the game…

i’ve told him that I’m not sure the cardboard keypad will work but who knows…


#74

I’ve been sharing this article with my team members these days because it fits so well with the project we are working on:

It’s about how traditional job interviews (which, everybody knows, are charades and very ineffective for seeing how good you will be at a job) are slowly but surely being replaced by situational tasks just like the game we are designing. We couldn’t be more happy!


#75

Hi Everyone!

I am having a problem with the most recent android render.

I have reported here: https://github.com/defold/editor2-issues/issues/2178

The only thing i can say is that it doesn’t appear to be related to the last issue i had with MacOS hidden files being considered duplicates.

Is it possible that my computer being suddenly unplugged during a previous build has caused some terrible problem? I first got the error then and haven’t been able to recover it since.


#76

Commented on the issue.


#77

…okay a quick update for anyone else who faces this problem.

You can use terminal to delete the pesky ._ files (dot underscore). This is the best way to do it (don’t download any paid software!) because it only deletes dot underscore files, not the normal hidden . (dot) files, which Github uses. Open Terminal and write

dot_clean /Volumes/MyDrive/Defoldproject

(assuming that your defold project is at /Volumes/MyDrive/Defoldproject). Then press enter.
You can also just type dot_clean and then drag the icon of your defold project folder into terminal to get the address automatically. Then press enter.

Check in the defold that the “changed files” show that you have deleted the troublesome file. Synchronise, and that’s it!

it would be great if defold’s browser displayed hidden files, or if there was a better warning system.


#78

mind_blown
Woah!! Did not know about dot_clean, really nice!


#79

I am nervous about dot clean. What are even in those ._ files? Why are they even more mysterious than normal . files? Are they safe to delete?


#80

Here is some information about the ._ files. https://apple.stackexchange.com/questions/14980/why-are-dot-underscore-files-created-and-how-can-i-avoid-them/15061


#81

There was one useful thing there… adding ._ to the gitignore file would help avoid the copying of these files. Apart from that, I am still unclear as to what information is stored in the ._ and what the risks are with deleting them (although it seems they are minimal).