Defold wont run 1.64

Hi, I am a new user here but having issues at step one. I have spent 2 hours trying to get the program to run on Windows 100 but double clicking teh defold.exe does nothing. I have tried:

-running with administrator rights
-Putting the Defold directory in various directories (C:/,D:/ drive roots etc)
-Re-installing /Updating Java manually
-Completely removing the separate installation of Java
-Swicthing off antivirus program
-Adding Defold to Windows defender whitelist

…but it still does nothing when I double click on it. Any ideas? I am on Windows 10 latest update. 32 Mb Ram, i7.

I cant seem to edit my posts on this forum either, so I shall just say that Windows 100 = Windows 10 :slight_smile:

The recommendation is to put it somewhere in user home, for instance on the desktop

Defold comes packaged with a Java version. No need to install one.

Could you please try to open Defold.exe from the command line?

I put the folder on the desktop and try to run from the command line but absolutely nothing happens…

Additionally I tried the steam version. That does nothing either. :frowning:
I haven’t had any issues with any other programs not running on my PC.

Here I try double clicking the steam version 3 times… It just stops immediately…

You might be able to find out some kind of log/error/warning by looking around the Windows Event Viewer software.

The editor keeps a log file. Might be worth a look


1 Like

Thanks. Lots of lines like this:
2024-02-12 17:07:57.334 189 [JavaFX-Launcher] WARN javafx - Unsupported JavaFX configuration: classes were loaded from 'unnamed module @5b399b10'

then this:
2024-02-12 13:54:58.680 3183 [Thread-4] ERROR com.defold.editor.Start - failed to extract native libs
java.lang.reflect.InvocationTargetException: null
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(
at java.base/java.lang.reflect.Method.invoke(
at com.defold.editor.Start.lambda$kickLoading$2(
at java.base/
Caused by: java.awt.AWTError: Assistive Technology not found:
at java.desktop/java.awt.Toolkit.newAWTError(
at java.desktop/java.awt.Toolkit.fallbackToLoadClassForAT(

The solution is this:

  1. Navigate to C:\Users\<username>
  2. Open the file called using a standard text editor (Notepad is fine)
  3. Find the following lines in the config:
  5. screen_magnifier_present=true
  6. Add a hashmark (#) in front of theses lines
  7. Save your changes to the file, restart the User Client Software
1 Like

Correct. That assistive technology software is somehow not compatible with Javafx. Also mentioned in our FAQ:

1 Like