Defold seems to hate me now


#1

I’m having issues with a few things now.

  1. The engine has been a bit finicky tonight, and crashes often when I try to do anything in the object view window.

  2. The engine crashes, once again often, but not every time, when I try to add a collision shape to a CO.

Here is the crash log file (There should have been multiple, but only one was created with today’s date). I’ll try and be gentle so I can make some progress. :cry:

hs_err_pid1664.zip (9.1 KB)


#2

Make that 2) every time now. I’m blocked again. :pensive:

EDIT: I’d also like to add, trying to view the collision shapes crashes the engine as well.
I was able to work around the issue by manually accessing and editing the code file.

One last thing: It’s Thanksgiving day tomorrow in the US, and I wanted to thank you guys for all the work you put into this engine. It’s amazing, and I really appreciate being able to use it.


#3

Thanks for the kind words, and for your own patience and help in tracking this bug down! Did you recently update your drivers? This looks like a combination of us doing something slightly wrong, and some drivers being more picky :wink:


#4

Not manually, no. I don’t recall any notifications popping up and letting me know that one was automatically installed either, but I could’ve just been oblivious.


#5

Seems that the issues are fixed in 1.2.142. I updated as soon as I saw the notifier, messed around, and couldn’t reproduce the problems. :grinning:


#6

With one fix comes a dozen bugs.

@Erik_Angelin

Once again, I cannot attach the sprite images to a sprite object. :frowning:

EDIT: Updated my Radeon graphics drivers and still nothing.

hs_err_pid6216.zip (9.0 KB)


#7

:frowning: Alright, I don’t think we can get this solved without getting hold of a machine so we can repro locally. This seems to be a workaround for a similar issue, perhaps there is some such setting you can try meanwhile: https://support.transmagic.com/hc/en-us/articles/206986713-Application-Crash-atio6axx-dll


#8

Ok, any eta on such a machine?


#9

No idea, will check on monday


#10

Well, I mean it is not like we will ever be able to buy, build and assemble every possible hardware configuration and it is unreasonable to believe that this will be fast and easily solvable. Are we sure that we have tried everything before rushing away to buy a graphics card?


#11

Well, with help from @Gmanicus and others we’ve tested quite a few hypotheses and workarounds to no avail. Having a machine with the same setup would surely cut down the iteration time. Let’s talk on monday.


#12

Right, and I wouldn’t expect you to.


#13

Thanks for the possible workaround Erik, but sadly I couldn’t follow the instructions. I have AMD Radeon, and Radeon doesn’t have the “Switchable graphics compatibility” that Catalyst does.

I’ll venture forth on other projects while I await King’s decision :slightly_smiling_face: