All sprites now cause engine to crash (SOLVED)


#1

Don’t have time to make a video of this or put this on github because I’m in a Jam right now. Quick description:

Once the atlas has been made, and the atlas has been added, create an object. Then, make the sprite component and add that sprite to it. You have to have it selected for axis movement. Next, try to “save all”. On the way to the “file” button, you’ll mouse over the ruler, and the engine will crash.

UPDATE: This happens even when trying to move the object with that sprite inside a collection. :weary::weary::weary:

So far only able to reproduce this randomly. It does occur with select sprites though. I don’t know what their similarities are. All sprites now cause the engine to crash.


Defold seems to hate me now
#2

The sprite in question:
derelict


#3

No longer over the ruler… I don’t know what the heck is going on.

I can’t add the sprite to the game. Renaming doesn’t work, remaking the file doesn’t work, deleting the files and starting over doesn’t work, nor does changing the sprite size…


#4

Can’t add any new sprites…

At this point I’m leaving the Jam. I’m probably going to have to reinstall Defold, but before I do, is there a file I can attach to help figure out what is going on?


#5

Hi @Gmanicus! Sad to hear it crashes and ruins your jam. Could be something with the image format? Can you try to open it and export it again? Make sure it has an alpha channel etc. If you get the dialog box with an option to report the issue, then please do report. If it’s a hard crash there might be additional info somewhere. On mac you often get a more detailed stacktrace for instance, that would help.


#6

@Erik_Angelin I’ve always used PNG, and never had issues with it before. I’ll try JPEG anyway.
I re-exported the file multiple times, and even remade it a couple times. It hard crashed. No dialog box, and no time to react. I’ll put the info on github sometime, and look for that report file.


#7

@Erik_Angelin As I thought, JPEG didn’t work either.

Here’s that error file you asked for:
hs_err_pid8528.zip (9.5 KB)


#8

Thanks! Very strange. Looks like it’s crashing when rendering the manipulators. I tried reproducing it but only have a mac at home. Will have a look next week!


#9

@Erik_Angelin I don’t know if sending you the project would do any better. Let me know if I can send you any of the files from the project or the engine files on my system to help diagnose things.


#10

If the project is hosted on defold servers you can add me to the team, otherwise please zip the project and mail me erik.angelin@king.com

Added https://github.com/defold/editor2-issues/issues/2270 to track this.


#11

@Erik_Angelin Just tested another project, same issue. Something went wrong with an Engine file.


#12

Seems to be working fine now with all the help from @Erik_Angelin! Don’t know if the issue has been fixed in the main update push, so I’m planning on marking this as “solved” when the next update is pushed.


#13

Several gl fixes have been merged into the normal channel, so feel free to close if it still works!


#14

Hey there. Got same issue(VideoCard AMD R9 380X) - i couldn’t open any sprite in editor, and for me worked some Radeon Settings


hs_err_pid13472.zip (9.5 KB)
It’ll be great, if it helps anyone.


#15

hs_err_pid9528.zip (9.6 KB)
Guys, it’s still there, i don’t know how can i fix it. Please somebody help. Can’t open any sprite.


#16

We believe the cause of the crash is our use of a deprecated method for selecting objects in the scene. A new solution is being worked on and will be out in a week or so.