Defold not starting on Windows 11

Have tried Defold numerous times on Windows 11 and it won’t run. Tried everything I can find, but it doesn’t launch. Please advise, Thank You.

Try running as Adminisrator or install Defold into user folder rather then Program Files.

Otherwise it might be helpful to post the most recent editor log here usually located at:



Still having same problem. I’m going to upload latest log file. (330 Bytes)
Please advise.

Is that really all there is in the log? It’s only two lines with warnings.

1 Like

Any Ideas, anyone… ? I still can’t ge DeFold to run on Windows 11. Please advise, Thank You.

Some questions:


  1. Which version of Defold did you download and from where?
  2. The download is a zip file. Where did you unpack it?
    • It is recommended to unpack to your user home folder
  3. Please share a screenshot of the contents of the folder you unpacked to so that we can verify that all files are there.


  1. How are you launching Defold? Clicking on the Defold.exe?
  2. What if you open a Windows command prompt, change directory to where you unpacked Defold and run Defold.exe? What is the output? Please share a screenshot.
  3. Have you tried running the version which is available on Steam?
  4. Do you have anti-virus software which might prevent Defold from starting?
  5. What if you run Defold as Administrator?