Defold menus not working properly linux

#1

Hello, I am using defold in arch linux, very interested on the game engine but found out when trying to open any of the mane tabs at the top they dont stay open for me to clikc on anyhting i have to leave the mouse click to the menu to stay open

0 Likes

#2

I have not heard of this problem before. @vlaaad or @mats.gisselson do you recognise this?

0 Likes

#3

SO, after a bit of testing i found out that this only happens when i am using a window manager I a usual desktop (Gnome) it worked perfectly, tried i3 same problem, and my main window manager Qtile and same problem.

1 Like

#4

using arch too with awesomewm and never had this issue, sorry can’t help.
the only problem i have is the ui keeps changing the size of the panes every time i start the editor, that’s all.

0 Likes

#5

I think is because the wm I use is tiled (Qtile)

0 Likes

#6

Hello!
I have tried the editor on Arch before and I also had problems when using dwm but it worked fine with Plasma. I do not know exactly what the reason is. It is probably a JavaFx problem. We currently have no workaround for this other than using a window manager where it works. Sorry.

2 Likes

#7

Oh OK, I have no problem just wanted to make sure it wasn’t something wrong on my end thanks!

1 Like