Defold Editor Not Starting in Linux

yes, I learned later that it does not work too and gave up for now because it is on the list to be fixed. Apologies for not updating the the thread.
Let’s hope it will be rather sooner than later :smile:

Download xulrunner from here:
And unpack somewhere

Add this lines to Defold.ini
-Dorg.eclipse.swt.browser.DefaultType=mozilla -Dorg.eclipse.swt.browser.XULRunnerPath=<path to xulrunner directory>
To fix git integration:
sudo apt-get install libssl0.9.8

And this enabled you to run Defold on Linux?

yes, it helped me to run defold editor on linux mint (32 bit)


Nice, thanks for sharing!

it does not work for me, the editor starts but any action seems not working with the error tab showing some null loop stuff.
there is also no libssl0.9.8 package on Ubuntu 15.10.

I posted som updates on this topic in another thread.

I can start editor but getting the same error if I start editor from the command line. But i’m running editor on MacOS El Capitan

Would you mind creating a new forum topic since your issue isn’t related to running the editor on Linux?

NOT work in Ubuntu 64 :sob::sob::sob:

Do you get an error message or anything else that hints at what’s wrong? It should work on Ubuntu.

What does it say if you run it from the terminal?

What version of Ubuntu are you running??
Our minimum supported Ubuntu version is now 16.04 (see release notes)

1 Like (83.7 KB)

my os ubuntu 16.04 LTS 64-bit

please see attached file

Hmm, I’m not sure why it behaves like that. Is this directly when you start the editor?

After some googling on your error, “org.eclipse.swt.SWTError: No more handles [gtk_init_check() failed]”, there are a few ideas:

  • The callstack suggests that you are having problems with the gtk package.
    What version of gtk do you have? (dpkg -l libgtk[0-9]* | grep ^i)

  • It could be related to your X server. Running as root could cause issues

  • It could be IPV6 related

I’ve tried to use root, and disable Ipv6, but It still ran for me :confused:

1 Like

I downloaded the Defold editor 1 on our Fedora and tested to open the file and nothing happening! Is i opening wrong file?:grinning:

And in Editor 2 is the building function not working!


There’s a progressbar bottom right in your last screenshot, at 73%. Doesn’t it reach 100%? And the status bottom left mentions that it writing files to disk. It looks like the builds are working, but I assume something goes wrong?

1 Like

How is this related to Defold or the problem you’re having?


sorry i was new and my dad said it to me after it :disappointed_relieved: