Debugging a missing texture (SOLVED)

#1

I’m having a strange problem with bundled iOS versions of my game. I stopped development for about 2 months, but resumed work this week. When I uploaded a new iOS build and sent it to TestFlight, parts of the build seems broken. I can’t see certain images and I’m not sure how to debug it. Everything works fine in the editor :frowning:

So my question is, how can I debug this on device? I tried using the “Sign iOS App…” option, but that just results in a disabled app icon on my phone. Are there any special logs I can access and or do I need to setup some special server that I send it to locally?

0 Likes

#2

Are you using tilemaps? We have a bug in 1.2.161 that will be fixed in the next release.

0 Likes

#3

No, I’m not using tile maps. It seems like a whole atlas is missing, the game is running properly but not rendering it.

1 Like

#4

Oh, ok, hmm, and it’s not rendered below the background or offscreen or something like that?

What if you create a new collection, add a game object and a sprite using something from the atlas and then boot with that collection? Does it render?

1 Like

#5

TL; DR: Exit the editor and open it again, then check for all the z-value including near z and far z; make sure they are correct.

I had exactly the same problem a few days ago. It was frustrated when it worked in the editor but not after I bundled.

I thought it was because of the z-index, so I changed some of the value for testing (including near z, far x, order of game objects - I was using orthographic camera). The problem remains.

Finally, I exit the editor and open again. Strangely near z and far z wasn’t saved. Now the editor does not show some of the game objects also. So I changed near z and far z; make sure z-order of all the game objects is within this range (which I did previously but does not work). And then it all working again.

I don’t know if this is gonna help you, but exit the editor and open it again helps me and I don’t even know why :slight_smile:

3 Likes

#6

I managed to find and solve the issue! I added one too many textures to one of my atlases so it got expanded to 8192x4096 instead of 4096x4096, so I guess it was just ignored. Moving some textures to another atlas solved the issue, so now I’m happy again :grin:

2 Likes

#7

Weird, it shouldn’t be ignored at least. Was this when running from the editor?

0 Likes

#8

No issues in the editor, didn’t show up on iOS.

1 Like